blob: 0895ce5b35a90a24c46937e2714493046232dd04 [file] [log] [blame]
Andrew Geissler89770b02020-06-13 10:40:47 -05001SUMMARY = "This is a filesystem client based on the HTTP using FUSE"
2HOMEPAGE = "http://httpfs.sourceforge.net"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://debian/copyright;md5=83f224c5182f148ec92e0b9f84b3c6c7"
5
6inherit pkgconfig
7
8DEPENDS += "fuse"
Patrick Williams213cb262021-08-07 19:21:33 -05009RDEPENDS:${PN} += "fuse"
Andrew Geissler89770b02020-06-13 10:40:47 -050010
11SRC_URI += "https://astuteinternet.dl.sourceforge.net/project/httpfs/httpfs2/httpfs2-${PV}.tar.gz"
12SRC_URI[sha256sum] = "01cb4bb38deb344f540da6f1464dc7edbdeb51213ad810b8c9c282c1e17e0fc1"
13
14S = "${WORKDIR}/httpfs2-${PV}"
15
16do_compile() {
17 cd ${S}
18 oe_runmake httpfs2
19}
20
21do_install() {
22 cd ${S}
23 install -d ${D}${bindir}
24 install -m 0755 httpfs2 ${D}${bindir}
25}