blob: fffd2b7df66622e347649a34c1bab0dee3e5e04a [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "NetworkManager GUI library"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5DEPENDS = "glib-2.0 gtk+3 networkmanager"
6
7GNOMEBASEBUILDCLASS = "meson"
8inherit gnomebase gobject-introspection gtk-doc gettext vala features_check
9
10REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('PACKAGECONFIG','gcr','x11','',d)}"
11ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
12
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050013SRC_URI[archive.md5sum] = "e1ccac96405861ecab195be5524baae6"
14SRC_URI[archive.sha256sum] = "da33e72a49e07d855d97a52aa9a8962a4c96f52b9168c4e0027117ad8ffdafb4"
Andrew Geissler82c905d2020-04-13 13:39:40 -050015
16PACKAGECONFIG ?= "gcr iso_codes mobile_broadband_provider_info"
17PACKAGECONFIG[gcr] = "-Dgcr=true,-Dgcr=false,gcr"
18PACKAGECONFIG[iso_codes] = "-Diso_codes=true,-Diso_codes=false,iso-codes,iso-codes"
19PACKAGECONFIG[mobile_broadband_provider_info] = "-Dmobile_broadband_provider_info=true,-Dmobile_broadband_provider_info=false,mobile-broadband-provider-info,mobile-broadband-provider-info"
20
Andrew Geisslere231d582020-05-05 08:53:09 -050021# go introspection is not supported for mipsn32/riscv32, but vapi needs it
Andrew Geissler82c905d2020-04-13 13:39:40 -050022#
Patrick Williams213cb262021-08-07 19:21:33 -050023EXTRA_OEMESON:append:mipsarchn32 = " -Dvapi=false"
24EXTRA_OEMESON:append:riscv32 = " -Dvapi=false"
25EXTRA_OEMESON:append:powerpc64le = " -Dvapi=false"
Andrew Geissler82c905d2020-04-13 13:39:40 -050026
27GTKDOC_MESON_OPTION = "gtk_doc"