blob: 9cca07175869733139d4ddd7a613bf97db1c10b8 [file] [log] [blame]
Andrew Geisslere231d582020-05-05 08:53:09 -05001SUMMARY = "A partition editor to graphically manage disk partitions "
2HOMEPAGE = "http://gparted.org/index.php"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
5
6inherit features_check autotools pkgconfig python3native gnome-help gtk-icon-cache
7
8REQUIRED_DISTRO_FEATURES = "x11"
9
10SRC_URI = " \
11 ${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}/${BPN}-${PV}/${BPN}-${PV}.tar.gz \
12 file://0001-Install-polkit-action-unconditionally-executable-pke.patch \
13"
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070014SRC_URI[sha256sum] = "8dc180245dd9ea45e6e2f4bc69512f187e08be7f799c98a825a0b04c161cbd2a"
Andrew Geisslere231d582020-05-05 08:53:09 -050015
16DEPENDS += " \
17 glib-2.0-native \
18 yelp-tools-native \
19 intltool-native \
20 glib-2.0 \
21 gtkmm3 \
22 parted \
23"
24
Patrick Williams213cb262021-08-07 19:21:33 -050025FILES:${PN} += " \
Andrew Geisslere231d582020-05-05 08:53:09 -050026 ${datadir}/appdata \
27 ${datadir}/icons \
28"
29
30PACKAGES += "${PN}-polkit"
Patrick Williams213cb262021-08-07 19:21:33 -050031FILES:${PN}-polkit = "${datadir}/polkit-1"
Andrew Geisslere231d582020-05-05 08:53:09 -050032
Patrick Williams213cb262021-08-07 19:21:33 -050033RDEPENDS:${PN} = " \
Andrew Geisslere231d582020-05-05 08:53:09 -050034 ${@bb.utils.contains('DISTRO_FEATURES', 'polkit', '${PN}-polkit', '', d)} \
35 dosfstools \
36 mtools \
37 e2fsprogs \
38"