blob: 9c599bbd8f267b4f33a5317f8cc45d775106100e [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001SUMMARY = "GNOME Flashback (GNOME 2) session"
2LICENSE = "GPLv3"
3LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
4
5inherit gnomebase gsettings gtk-icon-cache gettext upstream-version-is-even features_check
6
7REQUIRED_DISTRO_FEATURES = "x11 polkit systemd pam"
8
9DEPENDS += " \
10 upower \
11 ibus \
12 libxkbfile \
13 polkit \
14 metacity \
Andrew Geissler89770b02020-06-13 10:40:47 -050015 gdm \
Brad Bishope42b3e32020-01-15 22:08:42 -050016 gnome-desktop3 \
17 gnome-bluetooth \
Andrew Geissler89770b02020-06-13 10:40:47 -050018 gnome-panel \
Brad Bishope42b3e32020-01-15 22:08:42 -050019"
20
Andrew Geissler69721092021-07-23 12:57:00 -040021SRC_URI[archive.sha256sum] = "e03f33100f1982019c2e59bbdcd664549ec5caa0ef2d99e2c0e1272cea08bb3b"
Brad Bishope42b3e32020-01-15 22:08:42 -050022
Patrick Williams213cb262021-08-07 19:21:33 -050023do_install:append() {
Brad Bishope42b3e32020-01-15 22:08:42 -050024 # no oe-layer has compiz -> remove dead session
25 rm -f ${D}${datadir}/xsessions/gnome-flashback-compiz.desktop
26}
27
Patrick Williams213cb262021-08-07 19:21:33 -050028FILES:${PN} += " \
Brad Bishope42b3e32020-01-15 22:08:42 -050029 ${datadir}/desktop-directories \
Andrew Geissler89770b02020-06-13 10:40:47 -050030 ${datadir}/gnome-panel \
Brad Bishope42b3e32020-01-15 22:08:42 -050031 ${datadir}/gnome-session \
Andrew Geissler89770b02020-06-13 10:40:47 -050032 ${datadir}/xsessions \
33 ${libdir}/gnome-panel \
Brad Bishope42b3e32020-01-15 22:08:42 -050034 ${systemd_user_unitdir} \
35"
36
Patrick Williams213cb262021-08-07 19:21:33 -050037RDEPENDS:${PN} += "metacity"