blob: 0fa0b317042a59b57b422315d69353c5a7ef592c [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001SUMMARY = "GNOME tweaks: Advanced options for GNOME 3 session"
2LICENSE = "GPLv3 & CC0-1.0"
3LIC_FILES_CHKSUM = " \
4 file://LICENSES/CC0-1.0;md5=65d3616852dbf7b1a6d4b53b00626032 \
5 file://LICENSES/GPL-3.0;md5=9eef91148a9b14ec7f9df333daebc746 \
6"
7
8DEPENDS = "libhandy"
9
10GNOMEBASEBUILDCLASS = "meson"
11
12inherit gnomebase gtk-icon-cache gobject-introspection features_check upstream-version-is-even
13
14# same as gnome-shell
15REQUIRED_DISTRO_FEATURES = "x11 polkit systemd pam"
16
17# gobject-introspection is mandatory and cannot be configured
18REQUIRED_DISTRO_FEATURES += "gobject-introspection-data"
Patrick Williams213cb262021-08-07 19:21:33 -050019UNKNOWN_CONFIGURE_WHITELIST:append = " introspection"
Brad Bishope42b3e32020-01-15 22:08:42 -050020
21SRC_URI[archive.md5sum] = "a625d8b167c5549c68e1c6ac7a87d369"
22SRC_URI[archive.sha256sum] = "003326fab46e6faad9485924bca503f0c583e3b4553d6f673406eda396205250"
23SRC_URI += "file://0001-Make-python-path-configurable.patch"
24
25EXTRA_OEMESON = "-Dpython_site_dir=${PYTHON_SITEPACKAGES_DIR}"
26
Patrick Williams213cb262021-08-07 19:21:33 -050027FILES:${PN} += " \
Brad Bishope42b3e32020-01-15 22:08:42 -050028 ${datadir}/metainfo \
29 ${PYTHON_SITEPACKAGES_DIR} \
30"
31
Patrick Williams213cb262021-08-07 19:21:33 -050032RDEPENDS:${PN} += "gnome-shell python3-core python3-logging libhandy"