blob: 10b60be598d7f7d7cde160c6321f7f1778334341 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Portable C library for multiline text editing"
2HOMEPAGE = "http://projects.gnome.org/gtksourceview/"
3
4LICENSE = "LGPLv2.1"
5LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
6
7DEPENDS = "gtk+3 libxml2 intltool-native gnome-common-native glib-2.0-native"
8
9PNAME = "gtksourceview"
10
11S = "${WORKDIR}/${PNAME}-${PV}"
12
Brad Bishop93c3acf2019-10-29 09:48:15 -040013GNOMEBASEBUILDCLASS = "meson"
14
Brad Bishop8410d612019-11-25 09:40:59 -050015inherit gnomebase lib_package gettext features_check gtk-doc gobject-introspection vala
Brad Bishopc342db32019-05-15 21:57:59 -040016
17REQUIRED_DISTRO_FEATURES = "x11"
18
Andrew Geissler69721092021-07-23 12:57:00 -040019SRC_URI = "https://download.gnome.org/sources/gtksourceview/4.8/${PNAME}-${PV}.tar.xz"
20SRC_URI[sha256sum] = "d163d71b5fcafbc5b1eec6dd841edbdbcddd3a7511cd5fdcffd86b8bbfe69ac1"
Brad Bishop93c3acf2019-10-29 09:48:15 -040021
22GIR_MESON_OPTION = 'gir'
23GTKDOC_MESON_OPTION = "gtk_doc"
Brad Bishopc342db32019-05-15 21:57:59 -040024
Patrick Williams213cb262021-08-07 19:21:33 -050025# Override the definition in meson.bbclass. The dependencies in mason.build are incomplete
26# and the recipe will not build with "-j 1". This fix is benign but should be reviewed when
27# updating versions.
28#
29meson_do_compile() {
30 bbnote "========== generating gtksourceview-gresources.h ========"
31 bbnote "PARALLEL_MAKE is ${PARALLEL_MAKE}"
32 ninja ${PARALLEL_MAKE} gtksourceview/gtksourceview-gresources.h
33 bbnote "========== compiling target all ========"
34 ninja ${PARALLEL_MAKE}
35}
36
37FILES:${PN} += "${datadir}/gtksourceview-4"