blob: 3e6a5ba71103e3166518d854982ad2501665695d [file] [log] [blame]
Brad Bishop23eaf032019-11-20 05:15:02 -05001SUMMARY = "File manager for GNOME"
2SECTION = "x11/gnome"
3
4LICENSE="GPLv3"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=d32239bcb673463ab874e80d47fae504"
6
7GNOMEBASEBUILDCLASS = "meson"
8
9DEPENDS = " \
10 fontconfig \
11 gtk+3 \
12 gnome-desktop3 \
13 gsettings-desktop-schemas \
14 gnome-autoar \
15 tracker \
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070016 libhandy \
17 libportal \
Brad Bishop23eaf032019-11-20 05:15:02 -050018"
19
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070020inherit gnomebase gsettings gobject-introspection gtk-doc gettext features_check mime-xdg
Brad Bishop23eaf032019-11-20 05:15:02 -050021
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070022def gnome_verdir(v):
23 return oe.utils.trim_version(v, 1)
24
Andrew Geissler69721092021-07-23 12:57:00 -040025SRC_URI[archive.sha256sum] = "b71ef2fe07e5eea89a2bb1e5bd30947bd18873bfb30f79cbf17edfbd4d20f60d"
Brad Bishop23eaf032019-11-20 05:15:02 -050026
27REQUIRED_DISTRO_FEATURES = "x11"
28
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070029EXTRA_OEMESON += " \
30 -Dtests=none \
31"
32
Brad Bishop23eaf032019-11-20 05:15:02 -050033PACKAGECONFIG = "extensions"
34PACKAGECONFIG[extensions] = "-Dextensions=true,-Dextensions=false, gexiv2 gstreamer1.0-plugins-base"
35
Patrick Williams213cb262021-08-07 19:21:33 -050036FILES:${PN} += " \
Brad Bishop23eaf032019-11-20 05:15:02 -050037 ${datadir}/dbus-1 \
38 ${datadir}/metainfo \
39 ${datadir}/gnome-shell \
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070040 ${datadir}/tracker3 \
Brad Bishop23eaf032019-11-20 05:15:02 -050041"
Brad Bishope42b3e32020-01-15 22:08:42 -050042
43# mandatory - not checked during configuration:
44# | (org.gnome.Nautilus:863): GLib-GIO-ERROR **: 21:03:52.326: Settings schema 'org.freedesktop.Tracker.Miner.Files' is not installed
Patrick Williams213cb262021-08-07 19:21:33 -050045RDEPENDS:${PN} += "tracker-miners"