blob: 47e3f8dbbf7cce7df9aa7702fe1a983bab166083 [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001SUMMARY = "library to access web services that claim to be "RESTful""
Andrew Geisslereafcbb82020-06-05 17:59:17 -05002HOMEPAGE = "https://wiki.gnome.org/Projects/Librest"
Brad Bishope42b3e32020-01-15 22:08:42 -05003LICENSE = "LGPLv2.1"
4LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
5
6GNOMEBASEBUILDCLASS = "autotools"
7
8DEPENDS = " \
9 libxml2-native \
10 glib-2.0-native \
11 glib-2.0 \
12 libsoup-2.4 \
13"
14
15inherit gnomebase gobject-introspection gtk-doc vala
16
17SRC_URI[archive.md5sum] = "ece4547298a81105f307369d73c21b9d"
18SRC_URI[archive.sha256sum] = "0513aad38e5d3cedd4ae3c551634e3be1b9baaa79775e53b2dba9456f15b01c9"
19
20# * gnome environment requires libsoup build with in gnome PACKAGECONFIG
21# * libsoup-gnome support was removed upstream three years ago [1]
22# [1] https://gitlab.gnome.org/GNOME/librest/commit/8f904a8e2bb38a7bf72245cdf2f1ecad17e9a720
23EXTRA_OECONF = "--without-gnome"
24
Patrick Williams213cb262021-08-07 19:21:33 -050025do_configure:prepend() {
Brad Bishope42b3e32020-01-15 22:08:42 -050026 # rest expects introspection.m4 at custom location (see aclocal.m4).
27 cp -f ${STAGING_DIR_TARGET}/${datadir}/aclocal/introspection.m4 ${S}/build
28}
29
Patrick Williams213cb262021-08-07 19:21:33 -050030do_compile:prepend() {
Brad Bishope42b3e32020-01-15 22:08:42 -050031 export GIR_EXTRA_LIBS_PATH="${B}/rest/.libs"
32}
33