blob: b169afcf144c475c12a83279d18a1c9991a49106 [file] [log] [blame]
Brad Bishop2d39a062019-10-28 08:33:36 -04001SUMMARY = "Snowball compiler and stemming algorithms"
2HOMEPAGE = "https://snowballstem.org/"
3LICENSE = "BSD-3-Clause"
William A. Kennington IIIb95905d2021-06-02 12:40:56 -07004LIC_FILES_CHKSUM = "file://COPYING;md5=19139aaf3c8c8fa1ca6edd59c072fb9f"
Brad Bishop2d39a062019-10-28 08:33:36 -04005
Patrick Williams213cb262021-08-07 19:21:33 -05006DEPENDS:class-target = "${BPN}-native"
Brad Bishop2d39a062019-10-28 08:33:36 -04007
8SRC_URI = "\
9 git://github.com/snowballstem/snowball.git \
10 file://0001-Build-so-lib.patch \
Brad Bishop2d39a062019-10-28 08:33:36 -040011"
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070012SRCREV = "4764395431c8f2a0b4fe18b816ab1fc966a45837"
Brad Bishop2d39a062019-10-28 08:33:36 -040013S = "${WORKDIR}/git"
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070014PV = "2.1.0"
Brad Bishop2d39a062019-10-28 08:33:36 -040015LIBVER = "0.0.0"
16
17inherit lib_package
18
19BBCLASSEXTEND = "native"
20
Patrick Williams213cb262021-08-07 19:21:33 -050021do_compile:prepend:class-target() {
Brad Bishop2d39a062019-10-28 08:33:36 -040022 # use native tools
23 sed -i 's:./snowball :snowball :g' ${S}/GNUmakefile
24}
25
26do_install() {
27 install -d ${D}${bindir}
28 install -m 755 ${S}/snowball ${D}${bindir}
29 install -m 755 ${S}/stemwords ${D}${bindir}
30
31 install -d ${D}${libdir}
32 install -m 755 ${S}/libstemmer.so.${LIBVER} ${D}${libdir}/
33 ln -s libstemmer.so.${LIBVER} ${D}${libdir}/libstemmer.so.0
34 ln -s libstemmer.so.${LIBVER} ${D}${libdir}/libstemmer.so
35
36 install -d ${D}${includedir}
37 install -m 644 ${S}/include/*.h ${D}${includedir}
38}