blob: 0d1c4adc1d644d60a9ad90da90d3ce3b86c2ebe8 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001DESCRIPTION = "FreeRADIUS is an Internet authentication daemon, which implements the RADIUS \
2protocol, as defined in RFC 2865 (and others). It allows Network Access \
3Servers (NAS boxes) to perform authentication for dial-up users. There are \
4also RADIUS clients available for Web servers, firewalls, Unix logins, and \
5more. Using RADIUS allows authentication and authorization for a network to \
6be centralized, and minimizes the amount of re-configuration which has to be \
7done when adding or deleting new users."
8
9SUMMARY = "High-performance and highly configurable RADIUS server"
10HOMEPAGE = "http://www.freeradius.org/"
11SECTION = "System/Servers"
12LICENSE = "GPLv2 & LGPLv2+"
13LIC_FILES_CHKSUM = "file://LICENSE;md5=eb723b61539feef013de476e68b5c50a"
14DEPENDS = "openssl-native openssl libidn libtool libpcap libtalloc"
15
16SRC_URI = "git://github.com/FreeRADIUS/freeradius-server.git;branch=v3.0.x;lfs=0; \
17 file://freeradius \
18 file://volatiles.58_radiusd \
19 file://freeradius-enble-user-in-conf.patch \
20 file://freeradius-configure.ac-allow-cross-compilation.patch \
21 file://freeradius-libtool-detection.patch \
22 file://freeradius-configure.ac-add-option-for-libcap.patch \
23 file://freeradius-avoid-searching-host-dirs.patch \
24 file://freeradius-rlm_python-add-PY_INC_DIR.patch \
25 file://freeradius-libtool-do-not-use-jlibtool.patch \
26 file://freeradius-fix-quoting-for-BUILT_WITH.patch \
27 file://freeradius-fix-error-for-expansion-of-macro.patch \
28 file://0001-rlm_mschap-Use-includedir-instead-of-hardcoding-usr-.patch \
Andrew Geissler748a4832020-07-24 16:24:21 -050029 file://0001-raddb-certs-Makefile-fix-the-existed-certificate-err.patch \
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050030 file://0001-raddb-certs-Makefile-fix-the-occasional-verification.patch \
Andrew Geisslerac970dd2021-02-12 15:32:45 -060031 file://0001-workaround-error-with-autoconf-2.7.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050032 file://radiusd.service \
33 file://radiusd-volatiles.conf \
Andrew Geisslerf103a7f2021-05-07 16:09:40 -050034 file://check-openssl-cmds-in-script-bootstrap.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050035"
36
Andrew Geisslere34f8962021-04-15 15:53:51 -050037SRCREV = "af428abda249b2279ba0582180985a9f6f4a144a"
Andrew Geissler82c905d2020-04-13 13:39:40 -050038
39PARALLEL_MAKE = ""
40
41S = "${WORKDIR}/git"
42
Patrick Williams213cb262021-08-07 19:21:33 -050043LDFLAGS:append:powerpc = " -latomic"
44LDFLAGS:append:mipsarch = " -latomic"
45LDFLAGS:append:armv5 = " -latomic"
Andrew Geissler82c905d2020-04-13 13:39:40 -050046
47EXTRA_OECONF = " --enable-strict-dependencies \
48 --with-docdir=${docdir}/freeradius-${PV} \
49 --with-openssl-includes=${STAGING_INCDIR} \
50 --with-openssl-libraries=${STAGING_LIBDIR} \
51 --without-rlm_ippool \
52 --without-rlm_cache_memcached \
53 --without-rlm_counter \
54 --without-rlm_couchbase \
55 --without-rlm_dbm \
56 --without-rlm_eap_tnc \
57 --without-rlm_eap_ikev2 \
58 --without-rlm_opendirectory \
59 --without-rlm_redis \
60 --without-rlm_rediswho \
61 --without-rlm_sql_db2 \
62 --without-rlm_sql_firebird \
63 --without-rlm_sql_freetds \
64 --without-rlm_sql_iodbc \
65 --without-rlm_sql_oracle \
66 --without-rlm_sql_sybase \
67 --without-rlm_sql_mongo \
68 --without-rlm_sqlhpwippool \
69 --without-rlm_securid \
70 --without-rlm_unbound \
71 --without-rlm_python \
72 ac_cv_path_PERL=${bindir}/perl \
73 ax_cv_cc_builtin_choose_expr=no \
74 ax_cv_cc_builtin_types_compatible_p=no \
75 ax_cv_cc_builtin_bswap64=no \
76 ax_cv_cc_bounded_attribute=no \
77"
78
79PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)} \
80 pcre libcap \
81 openssl rlm-eap-fast rlm-eap-pwd \
82"
83
84PACKAGECONFIG[krb5] = "--with-rlm_krb5,--without-rlm_krb5,krb5"
85PACKAGECONFIG[pam] = "--with-rlm_pam,--without-rlm_pam,libpam"
86PACKAGECONFIG[libcap] = "--with-libcap,--without-libcap,libcap"
87PACKAGECONFIG[ldap] = "--with-rlm_ldap,--without-rlm_ldap,openldap"
88PACKAGECONFIG[mysql] = "--with-rlm_sql_mysql,--without-rlm_sql_mysql,mysql5"
89PACKAGECONFIG[sqlite] = "--with-rlm_sql_sqlite,--without-rlm_sql_sqlite,sqlite3"
90PACKAGECONFIG[unixodbc] = "--with-rlm_sql_unixodbc,--without-rlm_sql_unixodbc,unixodbc"
91PACKAGECONFIG[postgresql] = "--with-rlm_sql_postgresql,--without-rlm_sql_postgresql,postgresql"
92PACKAGECONFIG[pcre] = "--with-pcre,--without-pcre,libpcre"
93PACKAGECONFIG[perl] = "--with-perl=${STAGING_BINDIR_NATIVE}/perl-native/perl --with-rlm_perl,--without-rlm_perl,perl-native perl,perl"
94PACKAGECONFIG[python3] = "--with-rlm_python3 --with-rlm-python3-bin=${STAGING_BINDIR_NATIVE}/python3-native/python3 --with-rlm-python3-include-dir=${STAGING_INCDIR}/${PYTHON_DIR},--without-rlm_python3,python3-native python3"
95PACKAGECONFIG[rest] = "--with-rlm_rest,--without-rlm_rest,curl json-c"
96PACKAGECONFIG[ruby] = "--with-rlm_ruby,--without-rlm_ruby,ruby"
97PACKAGECONFIG[openssl] = "--with-openssl, --without-openssl"
98PACKAGECONFIG[rlm-eap-fast] = "--with-rlm_eap_fast, --without-rlm_eap_fast"
99PACKAGECONFIG[rlm-eap-pwd] = "--with-rlm_eap_pwd, --without-rlm_eap_pwd"
100
101inherit useradd autotools-brokensep update-rc.d systemd
102
103# This is not a cpan or python based package, but it needs some definitions
104# from cpan-base and python3-dir bbclasses for building rlm_perl and rlm_python
105# correctly.
106inherit cpan-base python3-dir
107
108# The modules subdirs also need to be processed by autoreconf. Use autogen.sh
109# in order to handle the subdirs correctly.
110do_configure () {
111 ./autogen.sh
112
113 # the configure of rlm_perl needs this to get correct
114 # mod_cflags and mod_ldflags
115 if ${@bb.utils.contains('PACKAGECONFIG', 'perl', 'true', 'false', d)}; then
116 export PERL5LIB="${STAGING_LIBDIR}${PERL_OWN_DIR}/perl/${@get_perl_version(d)}"
117 fi
118
119 oe_runconf
120
121 # we don't need dhcpclient
122 sed -i -e 's/dhcpclient.mk//' ${S}/src/modules/proto_dhcp/all.mk
123}
124
125INITSCRIPT_NAME = "radiusd"
126
Patrick Williams213cb262021-08-07 19:21:33 -0500127SYSTEMD_SERVICE:${PN} = "radiusd.service"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500128
129USERADD_PACKAGES = "${PN}"
Patrick Williams213cb262021-08-07 19:21:33 -0500130USERADD_PARAM:${PN} = "--system --no-create-home --shell /bin/false --user-group radiusd"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500131
132do_install() {
133 rm -rf ${D}
134 mkdir -p ${D}/${sysconfdir}/logrotate.d
135 mkdir -p ${D}/${sysconfdir}/pam.d
136 mkdir -p ${D}/${sysconfdir}/init.d
137 mkdir -p ${D}/${localstatedir}/lib/radiusd
138 mkdir -p ${D}${sysconfdir}/default/volatiles
139
140 export LD_LIBRARY_PATH=${D}/${libdir}
141 oe_runmake install R=${D} INSTALLSTRIP=""
142
143 # remove unsupported config files
144 rm -f ${D}/${sysconfdir}/raddb/experimental.conf
145
146 # remove scripts that required Perl(DBI)
147 rm -rf ${D}/${bindir}/radsqlrelay
148
149 cp -f ${WORKDIR}/freeradius ${D}/etc/init.d/radiusd
150 rm -f ${D}/${sbindir}/rc.radiusd
151 chmod +x ${D}/${sysconfdir}/init.d/radiusd
152 rm -rf ${D}/${localstatedir}/run/
153 rm -rf ${D}/${localstatedir}/log/
154 install -m 0644 ${WORKDIR}/volatiles.58_radiusd ${D}${sysconfdir}/default/volatiles/58_radiusd
155
156 chown -R radiusd:radiusd ${D}/${sysconfdir}/raddb/
157 chown -R radiusd:radiusd ${D}/${localstatedir}/lib/radiusd
158
159 # For systemd
160 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
161 install -d ${D}${systemd_unitdir}/system
162 install -m 0644 ${WORKDIR}/radiusd.service ${D}${systemd_unitdir}/system
163 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
164 -e 's,@SBINDIR@,${sbindir},g' \
165 -e 's,@STATEDIR@,${localstatedir},g' \
166 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
167 ${D}${systemd_unitdir}/system/radiusd.service
168
169 install -d ${D}${sysconfdir}/tmpfiles.d/
170 install -m 0644 ${WORKDIR}/radiusd-volatiles.conf ${D}${sysconfdir}/tmpfiles.d/radiusd.conf
171 fi
172}
173
174# This is only needed when we install/update on a running target.
175#
Patrick Williams213cb262021-08-07 19:21:33 -0500176pkg_postinst:${PN} () {
Andrew Geissler82c905d2020-04-13 13:39:40 -0500177 if [ -z "$D" ]; then
178 if command -v systemd-tmpfiles >/dev/null; then
179 # create /var/log/radius, /var/run/radiusd
180 systemd-tmpfiles --create ${sysconfdir}/tmpfiles.d/radiusd.conf
181 elif [ -e ${sysconfdir}/init.d/populate-volatile.sh ]; then
182 ${sysconfdir}/init.d/populate-volatile.sh update
183 fi
184
185 # Fix ownership for /etc/raddb/*, /var/lib/radiusd
186 chown -R radiusd:radiusd ${sysconfdir}/raddb
187 chown -R radiusd:radiusd ${localstatedir}/lib/radiusd
188 fi
189}
190
191# We really need the symlink :(
Patrick Williams213cb262021-08-07 19:21:33 -0500192INSANE_SKIP:${PN} = "dev-so"
193INSANE_SKIP:${PN}-krb5 = "dev-so"
194INSANE_SKIP:${PN}-ldap = "dev-so"
195INSANE_SKIP:${PN}-mysql = "dev-so"
196INSANE_SKIP:${PN}-perl = "dev-so"
197INSANE_SKIP:${PN}-postgresql = "dev-so"
198INSANE_SKIP:${PN}-python = "dev-so"
199INSANE_SKIP:${PN}-unixodbc = "dev-so"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500200
201PACKAGES =+ "${PN}-utils ${PN}-ldap ${PN}-krb5 ${PN}-perl \
202 ${PN}-python ${PN}-mysql ${PN}-postgresql ${PN}-unixodbc"
203
Patrick Williams213cb262021-08-07 19:21:33 -0500204FILES:${PN}-utils = "${bindir}/*"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500205
Patrick Williams213cb262021-08-07 19:21:33 -0500206FILES:${PN}-ldap = "${libdir}/rlm_ldap.so* \
Andrew Geissler82c905d2020-04-13 13:39:40 -0500207 ${sysconfdir}/raddb/mods-available/ldap \
208"
209
Patrick Williams213cb262021-08-07 19:21:33 -0500210FILES:${PN}-krb5 = "${libdir}/rlm_krb5.so* \
Andrew Geissler82c905d2020-04-13 13:39:40 -0500211 ${sysconfdir}/raddb/mods-available/krb5 \
212"
213
Patrick Williams213cb262021-08-07 19:21:33 -0500214FILES:${PN}-perl = "${libdir}/rlm_perl.so* \
Andrew Geissler82c905d2020-04-13 13:39:40 -0500215 ${sysconfdir}/raddb/mods-config/perl \
216 ${sysconfdir}/raddb/mods-available/perl \
217"
218
Patrick Williams213cb262021-08-07 19:21:33 -0500219FILES:${PN}-python = "${libdir}/rlm_python3.so* \
Andrew Geissler82c905d2020-04-13 13:39:40 -0500220 ${sysconfdir}/raddb/mods-config/python3 \
221 ${sysconfdir}/raddb/mods-available/python3 \
222"
223
Patrick Williams213cb262021-08-07 19:21:33 -0500224FILES:${PN}-mysql = "${libdir}/rlm_sql_mysql.so* \
Andrew Geissler82c905d2020-04-13 13:39:40 -0500225 ${sysconfdir}/raddb/mods-config/sql/*/mysql \
226 ${sysconfdir}/raddb/mods-available/sql \
227"
228
Patrick Williams213cb262021-08-07 19:21:33 -0500229FILES:${PN}-postgresql = "${libdir}/rlm_sql_postgresql.so* \
Andrew Geissler82c905d2020-04-13 13:39:40 -0500230 ${sysconfdir}/raddb/mods-config/sql/*/postgresql \
231"
232
Patrick Williams213cb262021-08-07 19:21:33 -0500233FILES:${PN}-unixodbc = "${libdir}/rlm_sql_unixodbc.so*"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500234
Patrick Williams213cb262021-08-07 19:21:33 -0500235FILES:${PN} =+ "${libdir}/rlm_*.so* ${libdir}/proto_*so*"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500236
Patrick Williams213cb262021-08-07 19:21:33 -0500237RDEPENDS:${PN} += "perl"
238RDEPENDS:${PN}-utils = "${PN} perl"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500239
240CLEANBROKEN = "1"