blob: 750b2521064cb3f5d16fef645d519abcd2cdd3b4 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "nanomsg socket library"
2DESCRIPTION = "nanomsg is a socket library that provides several common \
3communication patterns. It aims to make the networking layer fast, scalable, \
4and easy to use. Implemented in C, it works on a wide range of operating \
5systems with no further dependencies."
6HOMEPAGE = "https://nanomsg.org/"
7LICENSE = "MIT-X"
8LIC_FILES_CHKSUM = "file://COPYING;md5=587b3fd7fd291e418ff4d2b8f3904755"
9
10SECTION = "libs/networking"
11
12SRC_URI = "git://github.com/nanomsg/nanomsg.git;protocol=https"
13SRCREV = "1749fd7b039165a91b8d556b4df18e3e632ad830"
14
15S = "${WORKDIR}/git"
16
17inherit cmake pkgconfig
18
19# nanomsg documentation generation requires asciidoctor,
20# not asciidoc, and currently there's no asciidoctor-native
21# recipe anywhere in openembedded-core or meta-openembedded
22EXTRA_OECMAKE = " -DNN_ENABLE_DOC=OFF "
23
24# we don't want nanomsg-tools to be renamed to libnanomsg-tools
Patrick Williams213cb262021-08-07 19:21:33 -050025DEBIAN_NOAUTONAME:${PN}-tools = "1"
Brad Bishopc342db32019-05-15 21:57:59 -040026
27PACKAGES =+ "${PN}-tools"
Patrick Williams213cb262021-08-07 19:21:33 -050028FILES:${PN}-tools = "${bindir}/*"