blob: d5e9e2c30338a0bd3682798e7a856096f3e9b005 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "A 802.1ab implementation (LLDP) to help you locate neighbors of all your equipments"
2SECTION = "net/misc"
3LICENSE = "ISC"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/ISC;md5=f3b90e78ea0cffb20bf5cca7947a896d"
5
6DEPENDS = "libbsd libevent"
7
8SRC_URI = "\
9 http://media.luffy.cx/files/${BPN}/${BPN}-${PV}.tar.gz \
10 file://lldpd.init.d \
11 file://lldpd.default \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050012 "
13
Andrew Geisslere34f8962021-04-15 15:53:51 -050014SRC_URI[md5sum] = "000042dbf5b445f750b5ba01ab25c8ba"
15SRC_URI[sha256sum] = "98d200e76e30f6262c4a4493148c1840827898329146a57a34f8f0f928ca3def"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050016
17inherit autotools update-rc.d useradd systemd pkgconfig bash-completion
18
19USERADD_PACKAGES = "${PN}"
Patrick Williams213cb262021-08-07 19:21:33 -050020USERADD_PARAM:${PN} = "--system -g lldpd --shell /bin/false lldpd"
21GROUPADD_PARAM:${PN} = "--system lldpd"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050022
23EXTRA_OECONF += "--without-embedded-libevent \
24 --disable-oldies \
25 --with-privsep-user=lldpd \
26 --with-privsep-group=lldpd \
27 --with-systemdsystemunitdir=${systemd_system_unitdir} \
28 --without-sysusersdir \
29"
30
31PACKAGECONFIG ??= "cdp fdp edp sonmp lldpmed dot1 dot3"
32PACKAGECONFIG[xml] = "--with-xml,--without-xml,libxm2"
33PACKAGECONFIG[snmp] = "--with-snmp,--without-snmp,net-snmp"
34PACKAGECONFIG[readline] = "--with-readline,--without-readline,readline"
35PACKAGECONFIG[seccomp] = "--with-seccomp,--without-seccomp,libseccomp"
36PACKAGECONFIG[cdp] = "--enable-cdp,--disable-cdp"
37PACKAGECONFIG[fdp] = "--enable-fdp,--disable-fdp"
38PACKAGECONFIG[edp] = "--enable-edp,--disable-edp"
39PACKAGECONFIG[sonmp] = "--enable-sonmp,--disable-sonmp"
40PACKAGECONFIG[lldpmed] = "--enable-lldpmed,--disable-lldpmed"
41PACKAGECONFIG[dot1] = "--enable-dot1,--disable-dot1"
42PACKAGECONFIG[dot3] = "--enable-dot3,--disable-dot3"
43PACKAGECONFIG[custom] = "--enable-custom,--disable-custom"
44
45INITSCRIPT_NAME = "lldpd"
46INITSCRIPT_PARAMS = "defaults"
47
Patrick Williams213cb262021-08-07 19:21:33 -050048SYSTEMD_SERVICE:${PN} = "lldpd.service"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050049
Patrick Williams213cb262021-08-07 19:21:33 -050050do_install:append() {
Brad Bishopd7bf8c12018-02-25 22:55:05 -050051 install -Dm 0755 ${WORKDIR}/lldpd.init.d ${D}${sysconfdir}/init.d/lldpd
52 install -Dm 0644 ${WORKDIR}/lldpd.default ${D}${sysconfdir}/default/lldpd
53 # Make an empty configuration file
54 touch ${D}${sysconfdir}/lldpd.conf
55}
56
57PACKAGES =+ "${PN}-zsh-completion"
58
Patrick Williams213cb262021-08-07 19:21:33 -050059FILES:${PN} += "${libdir}/sysusers.d"
60RDEPENDS:${PN} += "os-release"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050061
Patrick Williams213cb262021-08-07 19:21:33 -050062FILES:${PN}-zsh-completion += "${datadir}/zsh/"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050063# FIXME: zsh is broken in meta-oe so this cannot be enabled for now
64#RDEPENDS_${PN}-zsh-completion += "zsh"