blob: 0f62b5790da630ac501a6356545c57cdc4be6f28 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001#
2# Copyright (C) 2012 Wind River Systems, Inc.
3#
4SUMMARY = "Provides a wrapper in Python to LDAP"
5DESCRIPTION = "This module provides access to the LDAP \
6(Lightweight Directory Access Protocol) through Python operations \
7instead of C API. The module mainly acts as a wrapper for the \
8OpenLDAP 2.x libraries. Errors will appear as exceptions."
9
10LICENSE = "PSF"
11HOMEPAGE = "http://www.python-ldap.org/"
12DEPENDS = "python3 openldap cyrus-sasl"
13
14PYPI_PACKAGE = "python-ldap"
15inherit pypi setuptools3
16
17LIC_FILES_CHKSUM = "file://LICENCE;md5=36ce9d726d0321b73c1521704d07db1b"
Andrew Geissler72956ed2021-01-08 16:11:14 -060018SRC_URI[md5sum] = "7608579722c491e42f5f63b3f88a95fb"
19SRC_URI[sha256sum] = "4711cacf013e298754abd70058ccc995758177fb425f1c2d30e71adfc1d00aa5"
Andrew Geissler82c905d2020-04-13 13:39:40 -050020
Patrick Williams213cb262021-08-07 19:21:33 -050021do_configure:prepend() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050022 sed -i -e 's:^library_dirs =.*::' ${S}/setup.cfg
23 sed -i -e 's:^include_dirs =.*:include_dirs = =/usr/include/sasl/:' ${S}/setup.cfg
24}
25
Patrick Williams213cb262021-08-07 19:21:33 -050026RDEPENDS:${PN} = " \
Andrew Geissler82c905d2020-04-13 13:39:40 -050027 ${PYTHON_PN}-pprint \
28 ${PYTHON_PN}-threading \
29 ${PYTHON_PN}-pyasn1 \
30 ${PYTHON_PN}-pyasn1-modules \
31"