blob: 48f97085603b92f05ad9dd12fd67baff696fc898 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SECTION = "console/utils"
2SUMMARY = "A free SOCKS server"
3DESCRIPTION = "Dante consists of a SOCKS server and a SOCKS client,\
4implementing RFC 1928 and related standards. It is a flexible product\
5that can be used to provide convenient and secure network\
6connectivity. Once installed, Dante can in most cases be made\
7transparent to clients, providing functionality somewhat similar to\
8what could be described as a non-transparent Layer 4 router."
9HOMEPAGE = "http://www.inet.no/dante/"
10
11LICENSE = "BSD-3-Clause"
12LIC_FILES_CHKSUM = "file://LICENSE;md5=221118dda731fe93a85d0ed973467249"
13
14SRC_URI = "https://www.inet.no/dante/files/dante-${PV}.tar.gz \
15 "
16SRC_URI[md5sum] = "68c2ce12119e12cea11a90c7a80efa8f"
17SRC_URI[sha256sum] = "b6d232bd6fefc87d14bf97e447e4fcdeef4b28b16b048d804b50b48f261c4f53"
18
19# without --without-gssapi, config.log will contain reference to /usr/lib
20# as a consequence of GSSAPI path being set to /usr by default.
21# --with-gssapi-path=PATH specify gssapi path
22# --without-gssapi disable gssapi support
23# --enable-release build prerelease as full release
24EXTRA_OECONF += "--without-gssapi --sbindir=${bindir}"
25
26DEPENDS += "flex-native bison-native libpam"
27
Brad Bishop8410d612019-11-25 09:40:59 -050028inherit autotools-brokensep features_check
Brad Bishop6e60e8b2018-02-01 10:27:11 -050029
30REQUIRED_DISTRO_FEATURES = "pam"
31
32EXTRA_AUTORECONF = "-I ${S}"
33
34PACKAGECONFIG[libwrap] = ",--disable-libwrap,tcp-wrappers,libwrap"
35PACKAGECONFIG[krb5] = ",--without-krb5,krb5"
36
37PACKAGECONFIG ??= ""
38
Patrick Williams213cb262021-08-07 19:21:33 -050039do_install:append() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050040 install -d ${D}${sysconfdir}
41 cp ${S}/example/sock[sd].conf ${D}${sysconfdir}
42}
43
44PACKAGES =+ "${PN}-sockd ${PN}-libdsocks "
45
Patrick Williams213cb262021-08-07 19:21:33 -050046FILES:${PN}-libdsocks = "${libdir}/libdsocks.so"
47FILES:${PN}-sockd = "${bindir}/sockd ${sysconfdir}/sockd.conf"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050048
Patrick Williams213cb262021-08-07 19:21:33 -050049INSANE_SKIP:${PN}-libdsocks = "dev-elf"