blob: 1ee04bd4753709d3eb96de22628a1a86e675f3d2 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001#
2# Copyright (C) 2014, 2015 Wind River Systems, Inc.
3# Released under the MIT license (see COPYING.MIT for the terms)
4#
5SUMMARY = "GeoIP perl API library to access location database"
6DESCRIPTION = "perl library for country/city/organization to IP address or hostname mapping"
7HOMEPAGE = "http://www.maxmind.com/app/ip-location"
8SECTION = "libdevel"
9LICENSE = "Artistic-1.0 | GPL-1.0+"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=e4f3ea6e9b28af88dc0321190a1f8250"
11
12S = "${WORKDIR}/git"
13SRCREV = "4cdfdc38eca237c19c22a8b90490446ce6d970fa"
Andrew Geissler32b11992021-03-31 13:37:05 -050014SRC_URI = "git://github.com/maxmind/geoip-api-perl.git;branch=main \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015 file://run-ptest \
16"
17
18DEPENDS += "geoip"
19
20inherit cpan ptest
21
22EXTRA_CPANFLAGS = "LIBS='-L${STAGING_LIBDIR}' INC='-I${STAGING_INCDIR}'"
23
24
25# perl scripts and some special small data files
26#
27do_install_ptest () {
28 install -d -m 0755 ${D}${PTEST_PATH}/t/data
29
30 install ${S}/t/*.t* ${D}${PTEST_PATH}/t
31 install ${S}/t/data/* ${D}${PTEST_PATH}/t/data
32}
33
Patrick Williams213cb262021-08-07 19:21:33 -050034FILES:${PN}-dbg += "${libdir}/perl/vendor_perl/*/auto/Geo/IP/.debug"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080035