blob: ad84593893be7e8bb89dad630f3d379a0b9b7a58 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "The tdb library"
2HOMEPAGE = "http://tdb.samba.org/"
3SECTION = "libs"
4LICENSE = "LGPL-3.0+ & GPL-3.0+"
5
6LIC_FILES_CHKSUM = "file://tools/tdbdump.c;endline=18;md5=b59cd45aa8624578126a8c98f48018c4 \
7 file://include/tdb.h;endline=27;md5=f5bb544641d3081821bcc1dd58310be6"
8
9SRC_URI = "https://samba.org/ftp/tdb/tdb-${PV}.tar.gz \
10 file://tdb-Add-configure-options-for-packages.patch \
11"
12
13SRC_URI[md5sum] = "e638e8890f743624a754304b3f994f4d"
14SRC_URI[sha256sum] = "c8058393dfa15f47e11ebd2f1d132693f0b3b3b8bf22d0201bfb305026f88a1b"
15
16PACKAGECONFIG ??= "\
17 ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)} \
18 ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'attr', '', d)} \
19"
20
21PACKAGECONFIG[acl] = "--with-acl,--without-acl,acl"
22PACKAGECONFIG[attr] = "--with-attr,--without-attr,attr"
23PACKAGECONFIG[libaio] = "--with-libaio,--without-libaio,libaio"
24PACKAGECONFIG[libbsd] = "--with-libbsd,--without-libbsd,libbsd"
25PACKAGECONFIG[libcap] = "--with-libcap,--without-libcap,libcap"
26PACKAGECONFIG[valgrind] = "--with-valgrind,--without-valgrind,valgrind"
27
28S = "${WORKDIR}/tdb-${PV}"
29
30inherit waf-samba
31
32#cross_compile cannot use preforked process, since fork process earlier than point subproces.popen
33#to cross Popen
34export WAF_NO_PREFORK="yes"
35
36EXTRA_OECONF += "--disable-rpath \
37 --bundled-libraries=NONE \
38 --builtin-libraries=replace \
39 --with-libiconv=${STAGING_DIR_HOST}${prefix}\
40 "
41
Patrick Williams213cb262021-08-07 19:21:33 -050042do_install:append() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050043 # add this link for cross check python module existence. eg: on x86-64 host, check python module
44 # under recipe-sysroot which is mips64.
45 cd ${D}${PYTHON_SITEPACKAGES_DIR}; ln -s tdb.*.so tdb.so
46}
47
48PACKAGES += "tdb-tools python3-tdb"
49
Patrick Williams213cb262021-08-07 19:21:33 -050050RPROVIDES:${PN}-dbg += "python3-tdb-dbg"
Andrew Geissler82c905d2020-04-13 13:39:40 -050051
Patrick Williams213cb262021-08-07 19:21:33 -050052FILES:${PN} = "${libdir}/*.so.*"
53FILES:tdb-tools = "${bindir}/*"
54FILES:python3-tdb = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/*"
55RDEPENDS:python3-tdb = "python3"
56INSANE_SKIP:${MLPREFIX}python3-tdb = "dev-so"