blob: 4e67f6c91b376650d1c8c2ddb09fd499fa5782ec [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "reimplement libdjb"
2DESCRIPTION = "libowfat is a library of general purpose APIs extracted from Dan \
3Bernstein's software (libdjb), reimplemented and covered by the GNU \
4General Public License Version 2 (no later versions)."
5HOMEPAGE = "http://www.fefe.de/libowfat"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
8
Brad Bishop2f973922019-11-11 07:58:48 -05009SRC_URI = "https://www.fefe.de/${BPN}/${BP}.tar.xz \
10 file://0001-Depend-on-haveuint128.h-for-umult64.c.patch \
Andrew Geisslerf103a7f2021-05-07 16:09:40 -050011 file://0001-replace-__pure__-with-compiler-attribute-pure.patch \
Brad Bishop2f973922019-11-11 07:58:48 -050012 "
Brad Bishop868407c2019-11-04 13:24:47 -050013SRC_URI[md5sum] = "ee015ccf45cb2bc61c942642038c2bdc"
14SRC_URI[sha256sum] = "f4b9b3d9922dc25bc93adedf9e9ff8ddbebaf623f14c8e7a5f2301bfef7998c1"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050015
16EXTRA_OEMAKE = "\
17 DIET= \
18 CC='${BUILD_CC} ${BUILD_CPPFLAGS} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}' \
19 CCC='${CC}' CFLAGS='${CFLAGS} -I.' CFLAGS_OPT='${CFLAGS} -I.' \
20"
21
22do_install() {
23 make install \
24 DESTDIR=${D} \
Brad Bishop868407c2019-11-04 13:24:47 -050025 INCLUDEDIR=${includedir} \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050026 LIBDIR=${libdir} \
27 MAN3DIR=${mandir}/man3
28}
29
Patrick Williams213cb262021-08-07 19:21:33 -050030ALLOW_EMPTY:${PN} = "1"
Andrew Geissler82c905d2020-04-13 13:39:40 -050031
Brad Bishop6e60e8b2018-02-01 10:27:11 -050032BBCLASSEXTEND = "native nativesdk"