blob: 3c89c377a744cca5517f45099727fa1eccf03127 [file] [log] [blame]
Andrew Geissler4b7c1152020-11-30 19:55:29 -06001SUMMARY = "Open-source IoT platform for data collection, processing, visualization, and device management"
2DESCRIPTION = "\
3The Thingsboard IoT Gateway is an open-source solution that allows you \
4to integrate devices connected to legacy and third-party systems with Thingsboard."
5HOMEPAGE = "https://thingsboard.io/"
6
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
9
10SRC_URI[md5sum] = "469c8b5cd1c16c20ef40f0a97a3a0fda"
11SRC_URI[sha256sum] = "b328f4e315c3541ac80a4931974a34a81afe4d1f382f48e8604669a55816c0d7"
12
13inherit pypi setuptools3
14
15PYPI_PACKAGE = "thingsboard-gateway"
16
Patrick Williams213cb262021-08-07 19:21:33 -050017RDEPENDS:${PN} += " python3-jsonpath-rw \
Andrew Geissler4b7c1152020-11-30 19:55:29 -060018 python3-regex \
19 python3-paho-mqtt \
20 python3-pyyaml \
21 python3-simplejson \
22 python3-requests \
23 python3-pip \
24 python3-pyrsistent \
25"
26
27SRC_URI += "file://bacnet.json \
28 file://ble.json \
29 file://can.json \
30 file://custom_serial.json \
31 file://modbus.json \
32 file://modbus_serial.json \
33 file://mqtt.json \
34 file://opcua.json \
35 file://odbc.json \
36 file://request.json \
37 file://rest.json \
38 file://snmp.json \
39 file://tb_gateway.yaml \
40 file://logs.conf \
41 file://thingsboard-gateway.service \
42 "
43
44
45inherit systemd
46
47SYSTEMD_PACKAGES = "${PN}"
Patrick Williams213cb262021-08-07 19:21:33 -050048SYSTEMD_SERVICE:${PN} = "thingsboard-gateway.service"
Andrew Geissler4b7c1152020-11-30 19:55:29 -060049
Patrick Williams213cb262021-08-07 19:21:33 -050050FILES:${PN} += "/etc \
Andrew Geissler4b7c1152020-11-30 19:55:29 -060051 /lib \
52 /usr \
53"
54
Patrick Williams213cb262021-08-07 19:21:33 -050055do_install:append(){
Andrew Geissler4b7c1152020-11-30 19:55:29 -060056
57 install -d ${D}${sysconfdir}/thingsboard-gateway/config
58
59 for file in $(find ${WORKDIR} -maxdepth 1 -type f -name *.json); do
60 install -m 0644 "$file" ${D}${sysconfdir}/thingsboard-gateway/config
61 done
62
63 install -m 0644 ${WORKDIR}/tb_gateway.yaml ${D}${sysconfdir}/thingsboard-gateway/config
64 install -m 0644 ${WORKDIR}/logs.conf ${D}${sysconfdir}/thingsboard-gateway/config
65
66 install -d ${D}${systemd_unitdir}/system/
67 install -m 0644 ${WORKDIR}/thingsboard-gateway.service ${D}${systemd_system_unitdir}/thingsboard-gateway.service
68}