blob: eff014a4cb75dc4b01614c1d4720d7f5f83889cd [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "mongodb"
2LICENSE = "SSPL-1 & Apache-2.0 & Zlib"
3LIC_FILES_CHKSUM = "file://LICENSE-Community.txt;md5=3a865f27f11f43ecbe542d9ea387dcf1 \
4 file://APACHE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
5
6DEPENDS = "openssl libpcap zlib boost curl python3 \
7 python3-setuptools-native \
8 python3-pyyaml-native python3-cheetah-native \
9 python3-psutil-native python3-regex-native \
10 "
11
Andrew Geisslerd688a012020-09-18 13:36:00 -050012inherit scons dos2unix siteinfo python3native systemd useradd
Andrew Geissler82c905d2020-04-13 13:39:40 -050013
Patrick Williams213cb262021-08-07 19:21:33 -050014PV = "4.4.7"
15#v4.4.7
16SRCREV = "abb6b9c2bf675e9e2aeaecba05f0f8359d99e203"
Andrew Geisslerd688a012020-09-18 13:36:00 -050017SRC_URI = "git://github.com/mongodb/mongo.git;branch=v4.4 \
Andrew Geissler82c905d2020-04-13 13:39:40 -050018 file://0001-Tell-scons-to-use-build-settings-from-environment-va.patch \
19 file://0001-Use-long-long-instead-of-int64_t.patch \
20 file://0001-Use-__GLIBC__-to-control-use-of-gnu_get_libc_version.patch \
21 file://0002-Add-a-definition-for-the-macro-__ELF_NATIVE_CLASS.patch \
22 file://arm64-support.patch \
23 file://0001-IntelRDFPMathLib20U1-Check-for-__DEFINED_wchar_t.patch \
24 file://0001-Support-deprecated-resolver-functions.patch \
25 file://0003-Fix-unknown-prefix-env.patch \
26 file://1296.patch \
Andrew Geisslerd688a012020-09-18 13:36:00 -050027 file://0001-Fix-compilation-with-fno-common.patch \
28 file://0001-stacktrace-Define-ARCH_BITS-for-x86.patch \
Andrew Geissler97771a32021-03-05 15:23:11 -060029 file://0001-include-needed-c-header.patch \
Andrew Geissler32b11992021-03-31 13:37:05 -050030 file://disable_runtime_check.patch \
31 file://ppc64_ARCH_BITS.patch \
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070032 file://0001-Do-not-use-MINSIGSTKSZ.patch \
33 file://0001-Use-explicit-typecast-to-size_t.patch \
Patrick Williams213cb262021-08-07 19:21:33 -050034 file://PTHREAD_STACK_MIN.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050035 "
Patrick Williams213cb262021-08-07 19:21:33 -050036SRC_URI:append:libc-musl ="\
Andrew Geissler82c905d2020-04-13 13:39:40 -050037 file://0001-Mark-one-of-strerror_r-implementation-glibc-specific.patch \
38 file://0002-Fix-default-stack-size-to-256K.patch \
39 file://0004-wiredtiger-Disable-strtouq-on-musl.patch \
40 "
41
Patrick Williams213cb262021-08-07 19:21:33 -050042SRC_URI:append:toolchain-clang = "\
Andrew Geissler82c905d2020-04-13 13:39:40 -050043 file://0001-asio-Dont-use-experimental-with-clang.patch \
44 "
45
Andrew Geisslerd688a012020-09-18 13:36:00 -050046
Andrew Geissler82c905d2020-04-13 13:39:40 -050047S = "${WORKDIR}/git"
48
49COMPATIBLE_HOST ?= '(x86_64|i.86|powerpc64|arm|aarch64).*-linux'
50
51PACKAGECONFIG ??= "tcmalloc system-pcre"
52# gperftools compilation fails for arm below v7 because of missing support of
53# dmb operation. So we use system-allocator instead of tcmalloc
Patrick Williams213cb262021-08-07 19:21:33 -050054PACKAGECONFIG:remove:armv6 = "tcmalloc"
55PACKAGECONFIG:remove:libc-musl = "tcmalloc"
56PACKAGECONFIG:remove:riscv64 = "tcmalloc"
57PACKAGECONFIG:remove:riscv32 = "tcmalloc"
Andrew Geissler82c905d2020-04-13 13:39:40 -050058
59PACKAGECONFIG[tcmalloc] = "--use-system-tcmalloc,--allocator=system,gperftools,"
60PACKAGECONFIG[shell] = ",--js-engine=none,,"
61PACKAGECONFIG[system-pcre] = "--use-system-pcre,,libpcre,"
62
Andrew Geissler32b11992021-03-31 13:37:05 -050063MONGO_ARCH ?= "${HOST_ARCH}"
Patrick Williams213cb262021-08-07 19:21:33 -050064MONGO_ARCH:powerpc64le = "ppc64le"
Andrew Geissler69721092021-07-23 12:57:00 -040065WIREDTIGER ?= "off"
Patrick Williams213cb262021-08-07 19:21:33 -050066WIREDTIGER:x86-64 = "on"
67WIREDTIGER:aarch64 = "on"
Andrew Geissler32b11992021-03-31 13:37:05 -050068
Andrew Geisslerd688a012020-09-18 13:36:00 -050069EXTRA_OESCONS = "PREFIX=${prefix} \
70 DESTDIR=${D} \
Andrew Geissler82c905d2020-04-13 13:39:40 -050071 LIBPATH=${STAGING_LIBDIR} \
72 LINKFLAGS='${LDFLAGS}' \
73 CXXFLAGS='${CXXFLAGS}' \
Andrew Geissler32b11992021-03-31 13:37:05 -050074 TARGET_ARCH=${MONGO_ARCH} \
Andrew Geisslerd688a012020-09-18 13:36:00 -050075 MONGO_VERSION=${PV} \
76 OBJCOPY=${OBJCOPY} \
Andrew Geissler82c905d2020-04-13 13:39:40 -050077 --ssl \
78 --disable-warnings-as-errors \
79 --use-system-zlib \
80 --nostrip \
81 --endian=${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'le', 'little', 'big', d)} \
Andrew Geissler69721092021-07-23 12:57:00 -040082 --wiredtiger='${WIREDTIGER}' \
Andrew Geisslerd688a012020-09-18 13:36:00 -050083 --separate-debug \
84 ${PACKAGECONFIG_CONFARGS}"
85
86
87USERADD_PACKAGES = "${PN}"
Patrick Williams213cb262021-08-07 19:21:33 -050088USERADD_PARAM:${PN} = "--system --no-create-home --home-dir /var/run/${BPN} --shell /bin/false --user-group ${BPN}"
Andrew Geisslerd688a012020-09-18 13:36:00 -050089
Andrew Geissler82c905d2020-04-13 13:39:40 -050090
91scons_do_compile() {
Andrew Geisslerd688a012020-09-18 13:36:00 -050092 ${STAGING_BINDIR_NATIVE}/scons ${PARALLEL_MAKE} ${EXTRA_OESCONS} install-core || \
Andrew Geissler82c905d2020-04-13 13:39:40 -050093 die "scons build execution failed."
94}
95
96scons_do_install() {
Andrew Geisslerd688a012020-09-18 13:36:00 -050097 # install binaries
98 install -d ${D}${bindir}
99 for i in mongod mongos mongo
100 do
101 if [ -f ${B}/build/opt/mongo/${i} ]
102 then
103 install -m 0755 ${B}/build/opt/mongo/${i} ${D}${bindir}/${i}
104 else
105 bbnote "${i} does not exist"
106 fi
107 done
108
109 # install config
110 install -d ${D}${sysconfdir}
111 install -m 0644 ${S}/debian/mongod.conf ${D}${sysconfdir}/
112
113 # install systemd service
114 install -d ${D}${systemd_system_unitdir}
115 install -m 0644 ${S}/debian/mongod.service ${D}${systemd_system_unitdir}
116
117 # install mongo data folder
118 install -m 755 -d ${D}${localstatedir}/lib/${BPN}
119 chown ${PN}:${PN} ${D}${localstatedir}/lib/${BPN}
120
121 # Log files
122 install -m 755 -d ${D}${localstatedir}/log/${BPN}
123 chown ${PN}:${PN} ${D}${localstatedir}/log/${BPN}
Andrew Geissler82c905d2020-04-13 13:39:40 -0500124}
Andrew Geisslerd688a012020-09-18 13:36:00 -0500125
Patrick Williams213cb262021-08-07 19:21:33 -0500126CONFFILES:${PN} = "${sysconfdir}/mongod.conf"
Andrew Geisslerd688a012020-09-18 13:36:00 -0500127
Patrick Williams213cb262021-08-07 19:21:33 -0500128SYSTEMD_SERVICE:${PN} = "mongod.service"