blob: 91387176b810a6efaf3c620941ff69a2c3ebca97 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Tests large file IO and creation/deletion of small files"
2HOMEPAGE = "http://www.coker.com.au/bonnie++/"
3SECTION = "benchmark/tests"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://copyright.txt;md5=cd4dde95a6b9d122f0a9150ae9cc3ee0"
6
7SRC_URI = "http://www.coker.com.au/bonnie++/${BPN}_${PV}.tgz \
8"
9SRC_URI[md5sum] = "1414aab86e2db1b4691bd4be82031012"
10SRC_URI[sha256sum] = "507bd2ce5360c7c98b91b0fdc2bed5c9320b5c9699f7d4a3d1c86b256896c15e"
11
12inherit autotools-brokensep
13
14SCRIPTS = "bon_csv2html bon_csv2txt"
15EXES = "bonnie++ zcav"
16
17TARGET_CC_ARCH += "${LDFLAGS}"
18
19do_install () {
20 install -d ${D}/${bindir}
21 install -d ${D}/${sbindir}
22 install -m 0755 ${EXES} ${D}/${sbindir}
23 install -m 0755 ${SCRIPTS} ${D}/${bindir}
24}
25
26PACKAGES =+ "bonnie-scripts"
27
Patrick Williams213cb262021-08-07 19:21:33 -050028FILES:${PN} = "${sbindir}"
29FILES:bonnie-scripts = "${bindir}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080030
Patrick Williams213cb262021-08-07 19:21:33 -050031RDEPENDS:bonnie-scripts += "perl"