blob: 186bc193084fdbd6f511374af7035a4cd7532c38 [file] [log] [blame]
Andrew Geissler8fc454f2020-12-11 16:27:59 -06001SUMMARY = "Linux Firmware Loader Daemon"
2DESCRIPTION = "The Linux Firmware Loader Daemon monitors the kernel for \
3firmware requests and uploads the firmware blobs it has via the sysfs \
4interface."
5HOMEPAGE = "https://github.com/teg/firmwared"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE-APACHE;md5=7b486c2338d225a1405d979ed2c15ce8 \
8 file://COPYING;md5=daa868b8e1ae17d03228a1145b4060da"
9
10SRC_URI = "git://github.com/teg/firmwared.git \
11 file://firmwared.service"
12
13PV = "0+git${SRCPV}"
14SRCREV = "2e6b5db43d63a5c0283a4cae9a6a20b7ad107a04"
15
16S = "${WORKDIR}/git"
17
18DEPENDS = "glib-2.0 systemd"
19
20inherit pkgconfig autotools systemd features_check
21
22REQUIRED_DISTRO_FEATURES = "systemd"
23
Patrick Williams213cb262021-08-07 19:21:33 -050024SYSTEMD_SERVICE:${PN} = "firmwared.service"
Andrew Geissler8fc454f2020-12-11 16:27:59 -060025
Patrick Williams213cb262021-08-07 19:21:33 -050026do_configure:prepend() {
Andrew Geissler8fc454f2020-12-11 16:27:59 -060027 ${S}/autogen.sh
28}
29
Patrick Williams213cb262021-08-07 19:21:33 -050030do_install:append() {
Andrew Geissler8fc454f2020-12-11 16:27:59 -060031 install -d ${D}${systemd_system_unitdir}
32 install -m 0644 ${WORKDIR}/firmwared.service ${D}${systemd_system_unitdir}
33 sed -i -e 's,@BINDIR@,${bindir},g' ${D}${systemd_system_unitdir}/firmwared.service
34}