blob: 220c0a8861f769796346711742cc0969d98f956f [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001# NOTE: mosh-server requires a UTF-8 locale, but there's no way to add
2# an explicit dependency for this so you need to ensure this is in your
3# image yourself when you install mosh-server.
4
5SUMMARY = "Remote shell supporting roaming and high-latency connections"
6DESCRIPTION = "Remote terminal application that allows roaming, supports \
7intermittent connectivity, and provides intelligent local echo and line \
8editing of user keystrokes. Mosh is a replacement for SSH. It's more \
9robust and responsive, especially over Wi-Fi, cellular, and \
10long-distance links."
11HOMEPAGE = "http://mosh.mit.edu"
12LICENSE = "GPLv3+"
13LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
14
15DEPENDS = "protobuf-native protobuf ncurses zlib libio-pty-perl openssl libutempter"
16
17SRC_URI = "http://mosh.mit.edu/mosh-${PV}.tar.gz \
18 file://0001-Fix-building-with-libc.patch \
19 "
20SRC_URI[md5sum] = "5122f4d2b973ab7c38dcdac8c35cb61e"
21SRC_URI[sha256sum] = "da600573dfa827d88ce114e0fed30210689381bbdcff543c931e4d6a2e851216"
22
23inherit autotools pkgconfig
24
25PACKAGE_BEFORE_PN += "${PN}-server"
Patrick Williams213cb262021-08-07 19:21:33 -050026FILES:${PN}-server = "${bindir}/mosh-server"
Brad Bishop19323692019-04-05 15:28:33 -040027
28NEEDED_PERL_MODULES = "\
29 perl-module-socket \
30 perl-module-getopt-long \
31 perl-module-errno \
32 perl-module-io-socket-inet \
33 perl-module-posix \
34"
35
36# mosh uses SSH to authenticate and the client uses OpenSSH-specific features
Patrick Williams213cb262021-08-07 19:21:33 -050037RDEPENDS:${PN} += "openssh-ssh ${NEEDED_PERL_MODULES}"
Brad Bishop19323692019-04-05 15:28:33 -040038# The server seemed not to work with dropbear either
Patrick Williams213cb262021-08-07 19:21:33 -050039RDEPENDS:${PN}-server += "openssh-sshd ${NEEDED_PERL_MODULES}"
Brad Bishop19323692019-04-05 15:28:33 -040040
41# Fails to build with thumb-1 (qemuarm)
42#| {standard input}: Assembler messages:
43#| {standard input}:2100: Error: instruction not supported in Thumb16 mode -- `adds r4,r4,r4'
44#| {standard input}:2101: Error: instruction not supported in Thumb16 mode -- `adcs r5,r5,r5'
45#| {standard input}:2102: Error: instruction not supported in Thumb16 mode -- `adcs r6,r6,r6'
46#| {standard input}:2103: Error: instruction not supported in Thumb16 mode -- `adcs r7,r7,r7'
47#| {standard input}:2104: Error: selected processor does not support Thumb mode `it cs'
48ARM_INSTRUCTION_SET = "arm"