blob: ed3bdbfe001eaed7f130d7ba2cb63b59dee3232b [file] [log] [blame]
Andrew Geissler72956ed2021-01-08 16:11:14 -06001SUMMARY = "D-Bus wrapper in C++ for dbus"
2HOMEPAGE = "https://dbus-cxx.github.io/"
3SECTION = "base"
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=4cf0188f02184e1e84b9586ac53c3f83"
6
Patrick Williams213cb262021-08-07 19:21:33 -05007FILEEXTRAPATHS:prepend = "${THISDIR}/files"
Andrew Geissler72956ed2021-01-08 16:11:14 -06008SRC_URI = "git://github.com/dbus-cxx/dbus-cxx.git;branch=master"
9SRC_URI += "file://fix_build_musl.patch"
10SRCREV = "ea7f8e361d11dc7d41d9ae2c4128aed2cdadd84e"
11
12DEPENDS = "\
13 dbus \
14 libsigc++-2.0 \
15"
16
Patrick Williams213cb262021-08-07 19:21:33 -050017RDEPENDS:${PN} = "\
Andrew Geissler72956ed2021-01-08 16:11:14 -060018 dbus \
19 libsigc++-2.0 \
20"
21
22S = "${WORKDIR}/git"
23
24inherit pkgconfig cmake
25
26OECMAKE_FIND_ROOT_PATH_MODE_PROGRAM = "BOTH"