blob: fa30f7cf40c88fc04e926f9bb812d225f9eb5187 [file] [log] [blame]
Andrew Geissler2ee498a2020-05-29 15:52:06 -05001SUMMARY = "Safe C Library"
2
3LICENSE = "safec"
4LIC_FILES_CHKSUM = "file://COPYING;md5=6d0eb7dfc57806a006fcbc4e389cf164"
5SECTION = "lib"
6
7inherit autotools pkgconfig
8
9S = "${WORKDIR}/git"
10# v08112019
11SRCREV = "ad76c7b1dbd0403b0c9decf54164fcce271c590f"
12SRC_URI = "git://github.com/rurban/safeclib.git \
13"
14
15COMPATIBLE_HOST = '(x86_64|i.86|powerpc|powerpc64|arm|aarch64|mips).*-linux'
16
17PACKAGES =+ "${PN}-check"
18
Patrick Williams213cb262021-08-07 19:21:33 -050019FILES:${PN}-check += "${bindir}/check_for_unsafe_apis"
Andrew Geissler2ee498a2020-05-29 15:52:06 -050020
Patrick Williams213cb262021-08-07 19:21:33 -050021RDEPENDS:${PN}-check += "perl"