blob: fa69aa14206a14127c78f555c90dd23838e67b4e [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001SUMMARY = "Count blank lines, comment lines, and physical lines of source code \
2in many programming languages."
3AUTHOR = "Al Danial"
4
5LICENSE="GPL-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=2c1c00f9d3ed9e24fa69b932b7e7aff2"
7
William A. Kennington IIIb95905d2021-06-02 12:40:56 -07008SRC_URI = "https://github.com/AlDanial/cloc/releases/download/v${PV}/${BP}.tar.gz"
9SRC_URI[md5sum] = "e2364c2c9c9eda1d20890c19911c51fb"
10SRC_URI[sha256sum] = "152502a61d4bae4a406a05a01bf52489b310ec03dbd8c645d0bb051fa4717ddb"
Brad Bishope42b3e32020-01-15 22:08:42 -050011
Andrew Geissler82c905d2020-04-13 13:39:40 -050012UPSTREAM_CHECK_URI = "https://github.com/AlDanial/${BPN}/releases"
13
Brad Bishope42b3e32020-01-15 22:08:42 -050014do_configure[noexec] = "1"
15do_compile[noexec] = "1"
16
17do_install() {
18 install -D -m 0755 ${S}/cloc ${D}${bindir}/cloc
19}
20
Patrick Williams213cb262021-08-07 19:21:33 -050021RDEPENDS:${PN} = "perl perl-modules"