blob: b6fdad27cb98706b150c4996dd4e536d40ad5de8 [file] [log] [blame]
Andrew Geisslerf103a7f2021-05-07 16:09:40 -05001# Copyright (C) 2015 Igor Santos <igor.santos@aker.com.br>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Universal Ctags"
5DESCRIPTION = "Universal Ctags is a multilanguage reimplementation of the \
6 Unix ctags utility. Ctags generates an index of source code \
7 definitions which is used by numerous editors and utilities \
8 to instantly locate the definitions."
9
10HOMEPAGE = "https://ctags.io/"
11
12LICENSE = "GPLv2"
13LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
14
15inherit autotools-brokensep pkgconfig manpages
16
Patrick Williams213cb262021-08-07 19:21:33 -050017SRCREV = "6544786c167ed3149d56e1ffe740c70513762197"
Andrew Geisslerf103a7f2021-05-07 16:09:40 -050018SRC_URI = "git://github.com/universal-ctags/ctags"
19
20S = "${WORKDIR}/git"
21
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070022PACKAGECONFIG ??= " \
23 readcmd \
24 xml \
25 json \
26 yaml \
27"
28PACKAGECONFIG[readcmd] = "--enable-readcmd,--disable-readcmd"
29PACKAGECONFIG[etags] = "--enable-etags,--disable-etags"
30PACKAGECONFIG[xml] = "--enable-xml,--disable-xml,libxml2"
31PACKAGECONFIG[json] = "--enable-json,--disable-json,jansson"
32PACKAGECONFIG[seccomp] = "--enable-seccomp,--disable-seccomp,libseccomp"
33PACKAGECONFIG[yaml] = "--enable-yaml,--disable-yaml,libyaml"
34PACKAGECONFIG[manpages] = ",,python3-docutils-native"