blob: a50679ae4f300ed33bd05416e98e3075036292f0 [file] [log] [blame]
Vijay Khemka6e220b32020-08-10 12:32:14 -07001SUMMARY = "Expression parser"
2HOMEPAGE = "https://github.com/ArashPartow/exprtk"
3SECTION = "libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
6SRCREV = "281c2ccc65b8f91c012ea3725ebcef406378a225"
7
8SRC_URI = "git://github.com/ArashPartow/exprtk.git"
9
10S = "${WORKDIR}/git"
11
12# other packages commonly reference the file directly as "exprtk.hpp"
13# create symlink to allow this usage
14do_install() {
15 install -d ${D}/${includedir}
16 install -m 0644 ${S}/exprtk.hpp ${D}/${includedir}/exprtk.hpp
17}
18
19# exprtk is a header only C++ library, so the main package will be empty.
Patrick Williams213cb262021-08-07 19:21:33 -050020RDEPENDS:${PN}-dev = ""
Vijay Khemka6e220b32020-08-10 12:32:14 -070021
22BBCLASSEXTEND = "native nativesdk"