blob: 6b18953b30e1a74ea6fc0af1b5fc6ebce5225e13 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001# Copyright (C) 2017 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "A console-based network monitoring utility"
5DESCRIPTION = "IPTraf-ng is a console-based network monitoring utility. IPTraf gathers \
6data like TCP connection packet and byte counts, interface statistics \
7and activity indicators, TCP/UDP traffic breakdowns, and LAN station \
8packet and byte counts. IPTraf-ng features include an IP traffic monitor \
9which shows TCP flag information, packet and byte counts, ICMP \
10details, OSPF packet types, and oversized IP packet warnings; \
11interface statistics showing IP, TCP, UDP, ICMP, non-IP and other IP \
12packet counts, IP checksum errors, interface activity and packet size \
13counts; a TCP and UDP service monitor showing counts of incoming and \
14outgoing packets for common TCP and UDP application ports, a LAN \
15statistics module that discovers active hosts and displays statistics \
16about their activity; TCP, UDP and other protocol display filters so \
17you can view just the traffic you want; logging; support for Ethernet, \
18FDDI, ISDN, SLIP, PPP, and loopback interfaces; and utilization of the \
19built-in raw socket interface of the Linux kernel, so it can be used \
20on a wide variety of supported network cards."
21
22HOMEPAGE = "https://fedorahosted.org/iptraf-ng/"
23LICENSE = "GPL-2.0"
24LIC_FILES_CHKSUM = "file://LICENSE;md5=e2b3850593b899b1a17594ed4cc4c731"
25DEPENDS = "ncurses"
26
27SRC_URI = "http://pkgs.fedoraproject.org/repo/pkgs/iptraf-ng/iptraf-ng-1.1.4.tar.gz/e0f8df3b7baf2b5106709abc4f8c029a/${BP}.tar.gz \
28 file://ncurses-config.patch \
29 file://0001-Fix-printd-formatting-strings.patch \
30 "
31SRC_URI[md5sum] = "e0f8df3b7baf2b5106709abc4f8c029a"
32SRC_URI[sha256sum] = "16b9b05bf5d3725d86409b901696639ad46944d02de6def87b1ceae5310dd35c"
33
34inherit autotools-brokensep pkgconfig
35
36CFLAGS += "-D_GNU_SOURCE"
37
38PROVIDES = "iptraf"
Patrick Williams213cb262021-08-07 19:21:33 -050039RPROVIDES:${PN} += "iptraf"
40RREPLACES:${PN} += "iptraf"
41RCONFLICTS:${PN} += "iptraf"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050042