blob: 39637663f62deb29e93014362637717818d6d092 [file] [log] [blame]
Patrick Williams213cb262021-08-07 19:21:33 -05001# Copyright (C) 2021 Mingli Yu <mingli.yu@windriver.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "General-purpose scalable concurrent malloc implementation"
5
6DESCRIPTION = "jemalloc is a general purpose malloc(3) implementation that emphasizes \
7fragmentation avoidance and scalable concurrency support."
8
9HOMEPAGE = "https://github.com/jemalloc/jemalloc"
10LICENSE = "BSD"
11
12SECTION = "libs"
13
14LIC_FILES_CHKSUM = "file://README;md5=6900e4a158982e4c4715bf16aa54fa10"
15
16SRC_URI = "git://github.com/jemalloc/jemalloc.git"
17
18SRCREV = "ea6b3e973b477b8061e0076bb257dbd7f3faa756"
19
20S = "${WORKDIR}/git"
21
22inherit autotools
23
24EXTRA_AUTORECONF += "--exclude=autoheader"
25
26EXTRA_OECONF:append:libc-musl = " --with-jemalloc-prefix=je_"