blob: 1664d637b770d5485e5e1823a68b21690f4cf751 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Linear Algebra PACKage"
2URL = "http://www.netlib.org/lapack"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=930f8aa500a47c7dab0f8efb5a1c9a40"
5
6# Recipe needs FORTRAN support (copied from conf/local.conf.sample.extended)
7# Enabling FORTRAN
8# Note this is not officially supported and is just illustrated here to
9# show an example of how it can be done
10# You'll also need your fortran recipe to depend on libgfortran
Patrick Williams213cb262021-08-07 19:21:33 -050011#FORTRAN:forcevariable = ",fortran"
12#RUNTIMETARGET:append:pn-gcc-runtime = " libquadmath"
Andrew Geissler82c905d2020-04-13 13:39:40 -050013
14DEPENDS = "libgfortran"
15
16SRCREV = "6acc99d5f39130be7cec00fb835606042101a970"
17SRC_URI = "git://github.com/Reference-LAPACK/lapack.git;protocol=https"
18S = "${WORKDIR}/git"
19
20EXTRA_OECMAKE = " -DBUILD_SHARED_LIBS=ON "
21OECMAKE_GENERATOR = "Unix Makefiles"
22
23inherit cmake pkgconfig
24EXCLUDE_FROM_WORLD = "1"