blob: f830e092595057f2e53159349511957f80439332 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001DESCRIPTION = "Lua is a powerful light-weight programming language designed \
2for extending applications."
3LICENSE = "MIT"
Andrew Geisslereef63862021-01-29 15:58:13 -06004LIC_FILES_CHKSUM = "file://doc/readme.html;beginline=318;endline=352;md5=f43d8ee6bc4df18ef8b276439cc4a153"
Brad Bishopc342db32019-05-15 21:57:59 -04005HOMEPAGE = "http://www.lua.org/"
6
Brad Bishopc342db32019-05-15 21:57:59 -04007SRC_URI = "http://www.lua.org/ftp/lua-${PV}.tar.gz;name=tarballsrc \
8 file://lua.pc.in \
Brad Bishop00ab2372019-10-14 11:06:18 -04009 file://0001-Allow-building-lua-without-readline-on-Linux.patch \
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050010 file://CVE-2020-15888.patch \
Andrew Geisslerd688a012020-09-18 13:36:00 -050011 file://CVE-2020-15945.patch \
12 file://0001-Fixed-bug-barriers-cannot-be-active-during-sweep.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040013 "
14
15# if no test suite matches PV release of Lua exactly, download the suite for the closest Lua release.
16PV_testsuites = "5.3.4"
17
18SRC_URI += "${@bb.utils.contains('DISTRO_FEATURES', 'ptest', \
19 'http://www.lua.org/tests/lua-${PV_testsuites}-tests.tar.gz;name=tarballtest \
20 file://run-ptest \
21 ', '', d)}"
22
Andrew Geisslereef63862021-01-29 15:58:13 -060023SRC_URI[tarballsrc.md5sum] = "83f23dbd5230140a3770d5f54076948d"
24SRC_URI[tarballsrc.sha256sum] = "fc5fd69bb8736323f026672b1b7235da613d7177e72558893a0bdcd320466d60"
Brad Bishopc342db32019-05-15 21:57:59 -040025SRC_URI[tarballtest.md5sum] = "b14fe3748c1cb2d74e3acd1943629ba3"
26SRC_URI[tarballtest.sha256sum] = "b80771238271c72565e5a1183292ef31bd7166414cd0d43a8eb79845fa7f599f"
27
28inherit pkgconfig binconfig ptest
29
Brad Bishop00ab2372019-10-14 11:06:18 -040030PACKAGECONFIG ??= "readline"
31PACKAGECONFIG[readline] = ",,readline"
32
Brad Bishopc342db32019-05-15 21:57:59 -040033TARGET_CC_ARCH += " -fPIC ${LDFLAGS}"
Brad Bishop00ab2372019-10-14 11:06:18 -040034EXTRA_OEMAKE = "'CC=${CC} -fPIC' 'MYCFLAGS=${CFLAGS} -fPIC' MYLDFLAGS='${LDFLAGS}'"
Brad Bishopc342db32019-05-15 21:57:59 -040035
Patrick Williams213cb262021-08-07 19:21:33 -050036do_configure:prepend() {
Brad Bishopc342db32019-05-15 21:57:59 -040037 sed -i -e s:/usr/local:${prefix}:g src/luaconf.h
Andrew Geissler82c905d2020-04-13 13:39:40 -050038 sed -i -e s:lib/lua/:${baselib}/lua/:g src/luaconf.h
Brad Bishopc342db32019-05-15 21:57:59 -040039}
40
41do_compile () {
Brad Bishop00ab2372019-10-14 11:06:18 -040042 oe_runmake ${@bb.utils.contains('PACKAGECONFIG', 'readline', 'linux', 'linux-no-readline', d)}
Brad Bishopc342db32019-05-15 21:57:59 -040043}
44
45do_install () {
46 oe_runmake \
47 'INSTALL_TOP=${D}${prefix}' \
48 'INSTALL_BIN=${D}${bindir}' \
49 'INSTALL_INC=${D}${includedir}/' \
50 'INSTALL_MAN=${D}${mandir}/man1' \
51 'INSTALL_SHARE=${D}${datadir}/lua' \
52 'INSTALL_LIB=${D}${libdir}' \
53 'INSTALL_CMOD=${D}${libdir}/lua/5.3' \
54 install
55 install -d ${D}${libdir}/pkgconfig
56
57 sed -e s/@VERSION@/${PV}/ ${WORKDIR}/lua.pc.in > ${WORKDIR}/lua.pc
58 install -m 0644 ${WORKDIR}/lua.pc ${D}${libdir}/pkgconfig/
59 rmdir ${D}${datadir}/lua/5.3
60 rmdir ${D}${datadir}/lua
61}
62
63do_install_ptest () {
64 cp -R --no-dereference --preserve=mode,links -v ${WORKDIR}/lua-${PV_testsuites}-tests ${D}${PTEST_PATH}/test
65}
66
67BBCLASSEXTEND = "native nativesdk"