blob: e3c407e6d57c9d69d7fdc9c7a87c68fff6c888d2 [file] [log] [blame]
Brad Bishop6a62e0e2019-10-21 08:11:42 -04001SUMMARY = "fifo maps for c++"
2HOMEPAGE = "https://github.com/nlohmann/fifo_map"
3SECTION = "libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=b67209a1e36b682a8226de19d265b1e0"
6
7SRC_URI = "git://github.com/nlohmann/fifo_map.git"
8
9PV = "1.0.0+git${SRCPV}"
10
11SRCREV = "0dfbf5dacbb15a32c43f912a7e66a54aae39d0f9"
12
Andrew Geissler82c905d2020-04-13 13:39:40 -050013UPSTREAM_CHECK_COMMITS = "1"
14
Brad Bishop6a62e0e2019-10-21 08:11:42 -040015S = "${WORKDIR}/git"
16
17# nlohmann-fifo is a header only C++ library, so the main package will be empty.
18
Patrick Williams213cb262021-08-07 19:21:33 -050019RDEPENDS:${PN}-dev = ""
Brad Bishop6a62e0e2019-10-21 08:11:42 -040020
21BBCLASSEXTEND = "native nativesdk"
22
23do_install() {
24 install -d ${D}${includedir}
25 install -m 0644 ${S}/src/fifo_map.hpp ${D}${includedir}
26}