blob: 311cf27307774f5ac70aee5dc00321fd8af4717a [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "The Perl Database Interface"
2DESCRIPTION = "DBI is a database access Application Programming Interface \
3(API) for the Perl Language. The DBI API Specification defines a set \
4of functions, variables and conventions that provide a consistent \
5database interface independent of the actual database being used. \
6"
7HOMEPAGE = "http://search.cpan.org/dist/DBI/"
8SECTION = "libs"
9LICENSE = "Artistic-1.0 | GPL-1.0+"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=10982c7148e0a012c0fd80534522f5c5"
11
12SRC_URI = "http://search.cpan.org/CPAN/authors/id/T/TI/TIMB/DBI-${PV}.tar.gz"
13SRC_URI[md5sum] = "352f80b1e23769c116082a90905d7398"
14SRC_URI[sha256sum] = "8a2b993db560a2c373c174ee976a51027dd780ec766ae17620c20393d2e836fa"
15
16S = "${WORKDIR}/DBI-${PV}"
17
18inherit cpan ptest-perl
19
Patrick Williams213cb262021-08-07 19:21:33 -050020do_install:prepend() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050021 # test requires "-T" (taint) command line option
22 rm -rf ${B}/t/pod-coverage.t
23 rm -rf ${B}/t/13taint.t
24 # source of test failure not obvious
25 rm -rf ${B}/t/85gofer.t
26 # unclear why there are several duplicates of tests in tarball
27 rm -rf ${B}/t/z*.t
28}
29
Patrick Williams213cb262021-08-07 19:21:33 -050030RDEPENDS:${PN}:class-target = " \
Andrew Geissler82c905d2020-04-13 13:39:40 -050031 perl \
32 perl-module-carp \
33 perl-module-exporter \
34 perl-module-exporter-heavy \
35 perl-module-dynaloader \
36 perl-module-io-dir \
37 perl-module-scalar-util \
38 perl-module-universal \
39"
40
Patrick Williams213cb262021-08-07 19:21:33 -050041RDEPENDS:${PN}-ptest = " \
Andrew Geissler82c905d2020-04-13 13:39:40 -050042 ${PN} \
43 perl-module-b \
44 perl-module-benchmark \
45 perl-module-cwd \
46 perl-module-data-dumper \
47 perl-module-encode \
48 perl-module-encode-byte \
49 perl-module-encode-encoding \
50 perl-module-file-copy \
51 perl-module-file-path \
52 perl-module-lib \
53 perl-module-perlio \
54 perl-module-perlio-scalar \
55 perl-module-perlio-via \
56 perl-module-sdbm-file \
57 perl-module-storable \
58 perl-module-test-more \
59 perl-module-utf8 \
60 "
61
62BBCLASSEXTEND = "native"