blob: b99d7b5ef629453f93bb970ab1489e86a0634cf8 [file] [log] [blame]
William A. Kennington IIIb95905d2021-06-02 12:40:56 -07001SUMMARY = "GNU poke is an extensible editor for structured binary data"
2HOMEPAGE = "https://pokology.org"
3DESCRIPTION = "GNU poke is an interactive, extensible editor for binary data. Not limited to editing basic entities such as bits and bytes, it provides a full-fledged procedural, interactive programming language designed to describe data structures and to operate on them."
4SECTION = "console/utils"
5LICENSE = "GPL-3.0+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
7
8SRC_URI = "${GNU_MIRROR}/poke/poke-${PV}.tar.gz \
9 file://0001-build-do-not-check-for-Tcl-Tk-if-disable-gui-is-spec.patch \
10 file://0002-jitter-jitter-config.in-avoit-host-poisoning-while-c.patch \
11 file://0003-configure.ac-HELP2MAN-replace-by-true-when-cross-com.patch \
12 "
13
14DEPENDS = "flex-native bison-native bdwgc readline"
15
16SRC_URI[sha256sum] = "f61cf8da5b64c01a1359373725aad1ca257f35c1c9269e4d50dd0664183ddf62"
17
18# poke does not support using out-of-tree builds
19inherit autotools-brokensep gettext pkgconfig
20
21# The automatic m4 path detection gets confused, so force the right value from
22# the poke bootstrap script.
23acpaths = "-I ./m4"
24
25EXTRA_OECONF = "--disable-gui \
26 --disable-libnbd \
27 --with-libreadline-prefix=${STAGING_INCDIR} \
28 "
29
30PACKAGECONFIG[mi] = "--enable-mi,--disable-mi,json-c"
31
Patrick Williams213cb262021-08-07 19:21:33 -050032FILES:${PN} += "${datadir}/emacs/site-lisp"