blob: 1a0bf535c96dc74fc0cb56af6787dbc4ef73670a [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Protocol Buffers - structured data serialisation mechanism"
2DESCRIPTION = "This is protobuf-c, a C implementation of the Google Protocol Buffers data \
3serialization format. It includes libprotobuf-c, a pure C library that \
4implements protobuf encoding and decoding, and protoc-c, a code generator that \
5converts Protocol Buffer .proto files to C descriptor code, based on the \
6original protoc. protobuf-c formerly included an RPC implementation; that code \
7has been split out into the protobuf-c-rpc project."
8HOMEPAGE = "https://github.com/protobuf-c/protobuf-c"
9SECTION = "console/tools"
10LICENSE = "BSD-2-Clause"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=cb901168715f4782a2b06c3ddaefa558"
12
13DEPENDS = "protobuf-native protobuf"
14
15SRCREV = "f20a3fa131c275a0e795d99a28f94b4dbbb5af26"
16
17SRC_URI = "git://github.com/protobuf-c/protobuf-c.git \
18 file://0001-avoid-race-condition.patch \
19 "
20
21S = "${WORKDIR}/git"
22
Andrew Geissler82c905d2020-04-13 13:39:40 -050023inherit autotools pkgconfig
24
Andrew Geisslerc87764f2020-06-27 00:16:32 -050025# After several fix attempts there is still a race between generating
26# t.test-full.pb.h and compiling cxx_generate_packed_data.c despite
27# BUILT_SOURCES and explicit dependencies.
28PARALLEL_MAKE = ""
29
Andrew Geissler82c905d2020-04-13 13:39:40 -050030PACKAGE_BEFORE_PN = "${PN}-compiler"
31
Patrick Williams213cb262021-08-07 19:21:33 -050032FILES:${PN}-compiler = "${bindir}"
Andrew Geissler82c905d2020-04-13 13:39:40 -050033
Patrick Williams213cb262021-08-07 19:21:33 -050034RDEPENDS:${PN}-compiler = "protobuf-compiler"
35RDEPENDS:${PN}-dev += "${PN}-compiler"
Andrew Geissler82c905d2020-04-13 13:39:40 -050036
37BBCLASSEXTEND = "native nativesdk"