blob: 384dd5129cb4be81fcd27476fb9c94efa4f033dd [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "A fast JSON parser/generator for C++ with both SAX/DOM style API"
2HOMEPAGE = "http://rapidjson.org/"
3SECTION = "libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://license.txt;md5=ba04aa8f65de1396a7e59d1d746c2125"
6
Andrew Geisslereef63862021-01-29 15:58:13 -06007SRC_URI = "git://github.com/miloyip/rapidjson.git;nobranch=1"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05008
Andrew Geisslereef63862021-01-29 15:58:13 -06009SRCREV = "0ccdbf364c577803e2a751f5aededce935314313"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050010
11PV = "1.1.0+git${SRCPV}"
12
13S = "${WORKDIR}/git"
14
15inherit cmake
16
Andrew Geissler69721092021-07-23 12:57:00 -040017EXTRA_OECMAKE += "-DRAPIDJSON_BUILD_DOC=OFF -DRAPIDJSON_BUILD_TESTS=OFF -DRAPIDJSON_BUILD_EXAMPLES=OFF"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050018
19# RapidJSON is a header-only C++ library, so the main package will be empty.
20
Patrick Williams213cb262021-08-07 19:21:33 -050021ALLOW_EMPTY:${PN} = "1"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050022
23BBCLASSEXTEND = "native nativesdk"