blob: 792cdb5378f49107e416c1313b739c562e88370b [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "SIP is a C++/Python Wrapper Generator"
Andrew Geisslerc87764f2020-06-27 00:16:32 -05002HOMEPAGE = "https://riverbankcomputing.com/software/sip/"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08003SECTION = "devel"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://LICENSE-GPL2;md5=e91355d8a6f8bd8f7c699d62863c7303"
6
Brad Bishopc342db32019-05-15 21:57:59 -04007SRC_URI = "https://www.riverbankcomputing.com/static/Downloads/sip/${PV}/sip-${PV}.tar.gz \
Brad Bishop87b3cb82019-11-15 16:35:37 -05008"
Andrew Geisslerc87764f2020-06-27 00:16:32 -05009SRC_URI[md5sum] = "70adc0c9734e2d9dcd241d3f931dfc74"
10SRC_URI[sha256sum] = "22ca9bcec5388114e40d4aafd7ccd0c4fe072297b628d0c5cdfa2f010c0bc7e7"
11
12inherit python3-dir python3native
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013
14S = "${WORKDIR}/sip-${PV}"
15
Andrew Geisslerc87764f2020-06-27 00:16:32 -050016DEPENDS = "python3"
17
18PACKAGES += "python3-sip3"
19
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080020BBCLASSEXTEND = "native"
21
Andrew Geisslereef63862021-01-29 15:58:13 -060022CONFIGURE_SYSROOT = "${STAGING_DIR_HOST}"
Patrick Williams213cb262021-08-07 19:21:33 -050023CONFIGURE_SYSROOT:class-native = "${STAGING_DIR_NATIVE}"
Andrew Geisslerc87764f2020-06-27 00:16:32 -050024
Patrick Williams213cb262021-08-07 19:21:33 -050025do_configure:prepend() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080026 echo "py_platform = linux" > sip.cfg
Andrew Geisslereef63862021-01-29 15:58:13 -060027 echo "py_inc_dir = ${STAGING_INCDIR}/python%(py_major).%(py_minor)${PYTHON_ABI}" >> sip.cfg
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080028 echo "sip_bin_dir = ${D}/${bindir}" >> sip.cfg
29 echo "sip_inc_dir = ${D}/${includedir}" >> sip.cfg
Brad Bishopc342db32019-05-15 21:57:59 -040030 echo "sip_module_dir = ${D}/${libdir}/python%(py_major).%(py_minor)/site-packages" >> sip.cfg
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080031 echo "sip_sip_dir = ${D}/${datadir}/sip" >> sip.cfg
Andrew Geisslereef63862021-01-29 15:58:13 -060032 ${PYTHON} configure.py --configuration sip.cfg --sip-module PyQt5.sip --sysroot ${CONFIGURE_SYSROOT} CC="${CC}" CXX="${CXX}" LINK="${CXX}" STRIP="" LINK_SHLIB="${CXX}" CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" LFLAGS="${LDFLAGS}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080033}
Andrew Geisslerc87764f2020-06-27 00:16:32 -050034
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080035do_install() {
36 oe_runmake install
37}
Andrew Geisslerc87764f2020-06-27 00:16:32 -050038
Patrick Williams213cb262021-08-07 19:21:33 -050039FILES:python3-sip3 = "${libdir}/${PYTHON_DIR}/site-packages/"
40FILES:${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/.debug"