blob: 6d55c58526f19f81b6402a440e87f1062aebb0b3 [file] [log] [blame]
Andrew Geissler32b11992021-03-31 13:37:05 -05001SUMMARY = "Templatized C++ Command Line Parser"
2HOMEPAGE = "http://tclap.sourceforge.net/"
3DESCRIPTION = "TCLAP is a small, flexible library that provides a simple interface \
4for defining and accessing command line arguments. It was intially inspired by the \
5user friendly CLAP libary. The difference is that this library is templatized, so \
6the argument class is type independent. Type independence avoids identical-except-for-type \
7objects, such as IntArg, FloatArg, and StringArg. While the library is not strictly \
8compliant with the GNU or POSIX standards, it is close. \
9"
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://COPYING;md5=5c64b2e8cc50917b2744a90950faa7cd"
12
13SRCREV = "799a8b1f99818e39fee19d0601030770af1221e1"
14SRC_URI = "git://git.code.sf.net/p/tclap/code;branch=1.4 \
15 file://0001-tclap-add-pkg-config-file.patch \
16"
17
18S = "${WORKDIR}/git"
19inherit cmake
20
Patrick Williams213cb262021-08-07 19:21:33 -050021ALLOW_EMPTY:${PN} = "1"
Andrew Geissler32b11992021-03-31 13:37:05 -050022
23BBCLASSEXTEND = "native nativesdk"