blob: 0acd09995657cd1a9f623244a0737f42732a5000 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001# Copyright (C) 2016 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Open-source software for volunteer computing"
5DESCRIPTION = "The Berkeley Open Infrastructure for Network Computing (BOINC) is an open- \
6source software platform which supports distributed computing, primarily in \
7the form of volunteer computing and desktop Grid computing. It is well \
8suited for problems which are often described as trivially parallel. BOINC \
9is the underlying software used by projects such as SETI@home, Einstein@Home, \
10ClimatePrediciton.net, the World Community Grid, and many other distributed \
11computing projects. \
12This package installs the BOINC client software, which will allow your \
13computer to participate in one or more BOINC projects, using your spare \
14computer time to search for cures for diseases, model protein folding, study \
15global warming, discover sources of gravitational waves, and many other types \
16of scientific and mathematical research."
17
18HOMEPAGE = "http://boinc.berkeley.edu/"
19LICENSE = "LGPLv2+ & GPLv3"
20LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
21 file://COPYING.LESSER;md5=6a6a8e020838b23406c81b19c1d46df6"
22SECTION = "applications"
23DEPENDS = "curl \
24 jpeg \
25 openssl \
26 sqlite3 \
27 virtual/libgl \
28 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'libnotify', '', d)} \
29 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'gtk+ libnotify xcb-util libxscrnsaver', '', d)} \
30 nettle \
31"
Andrew Geisslerac970dd2021-02-12 15:32:45 -060032SRCREV = "df0239e6f074207798a8ecf1358a74545dda9132"
33BRANCH = "client_release/7/7.16"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080034SRC_URI = "git://github.com/BOINC/boinc;protocol=https;branch=${BRANCH} \
35 file://boinc-AM_CONDITIONAL.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080036 file://gtk-configure.patch \
37"
38
Brad Bishop8410d612019-11-25 09:40:59 -050039inherit gettext autotools pkgconfig features_check systemd
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080040
41REQUIRED_DISTRO_FEATURES += "opengl"
42
43S = "${WORKDIR}/git"
44
45EXTRA_OECONF += "\
46 --enable-libraries \
47 --enable-unicode \
48 --enable-shared \
49 --enable-dynamic-client-linkage \
50 --enable-client \
51 --disable-server \
52 --disable-static \
53 --disable-manager \
54 --with-ssl=${STAGING_EXECPREFIXDIR} \
55 --without-wxdir \
56 --without-x \
57 --with-boinc-platform=${TARGET_SYS} \
Andrew Geisslerac970dd2021-02-12 15:32:45 -060058 ac_cv_c_undeclared_builtin_options='none' \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080059"
60export PKG_CONFIG = "${STAGING_BINDIR_NATIVE}/pkg-config"
61
Patrick Williams213cb262021-08-07 19:21:33 -050062do_configure:prepend () {
Andrew Geisslerac970dd2021-02-12 15:32:45 -060063 if [ "${@bb.utils.contains('DEPENDS', 'gtk+', '1', '0', d)}" = "0" ]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080064 then
65 export GTK2_CFLAGS=""
66 export GTK2_LIBS=""
67 fi
68}
69
Patrick Williams213cb262021-08-07 19:21:33 -050070do_compile:prepend () {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080071 # Disable rpaths
72 sed -i -e 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' ${B}/${TARGET_SYS}-libtool
73 sed -i -e 's|^sys_lib_dlsearch_path_spec=.*|sys_lib_dlsearch_path_spec=""|g' ${B}/${TARGET_SYS}-libtool
74 sed -i -e 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' ${B}/${TARGET_SYS}-libtool
75}
Andrew Geissler82c905d2020-04-13 13:39:40 -050076
Patrick Williams213cb262021-08-07 19:21:33 -050077do_install:append() {
Brad Bishope42b3e32020-01-15 22:08:42 -050078 if [ -e ${D}${nonarch_libdir}/systemd/system/boinc-client.service ]; then
Andrew Geissler82c905d2020-04-13 13:39:40 -050079 install -d ${D}${systemd_system_unitdir}
Brad Bishope42b3e32020-01-15 22:08:42 -050080 mv \
81 ${D}${nonarch_libdir}/systemd/system/boinc-client.service \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080082 ${D}${systemd_system_unitdir}/boinc-client.service
Brad Bishope42b3e32020-01-15 22:08:42 -050083 rmdir --ignore-fail-on-non-empty ${D}${nonarch_libdir}/systemd/system \
Andrew Geissler82c905d2020-04-13 13:39:40 -050084 ${D}${nonarch_libdir}/systemd \
85 ${D}${nonarch_libdir}
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080086 fi
87}
88
Patrick Williams213cb262021-08-07 19:21:33 -050089SYSTEMD_SERVICE:${PN} = "boinc-client.service"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080090
Patrick Williams213cb262021-08-07 19:21:33 -050091FILES:${PN} += "${libdir}/systemd"