blob: 92d6d9f186e195775afd62b966c7efc15ca6bd0b [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Lossless compression library and tool"
Andrew Geisslereafcbb82020-06-05 17:59:17 -05002DESCRIPTION = "Brotli is a generic-purpose lossless compression algorithm \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08003that it is similar in speed to deflate but offers more dense compression."
4HOMEPAGE = "https://github.com/google/brotli"
5BUGTRACKER = "https://github.com/google/brotli/issues"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=941ee9cd1609382f946352712a319b4b"
8
Andrew Geisslerd688a012020-09-18 13:36:00 -05009SRC_URI = "git://github.com/google/brotli.git \
10 file://838.patch "
11# tag 1.0.9
12SRCREV= "e61745a6b7add50d380cfd7d3883dd6c62fc2c71"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013S = "${WORKDIR}/git"
14
15inherit cmake lib_package
Brad Bishope42b3e32020-01-15 22:08:42 -050016
Patrick Williams213cb262021-08-07 19:21:33 -050017do_install:append () {
Brad Bishope42b3e32020-01-15 22:08:42 -050018 for lib in $(ls ${D}${libdir}/*-static.a); do
19 mv -v "${lib}" "$(echo ${lib} | sed s/-static//)"
20 done
21}
Andrew Geissler82c905d2020-04-13 13:39:40 -050022
23BBCLASSEXTEND = "native"