blob: 4ef3fc15ad72e3255598da9b3324e625dffcc956 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001#
2# Copyright (C) 2014 - 2017 Wind River Systems, Inc.
3#
4SUMMARY = "Base policy for CFEngine"
5
6DESCRIPTION = "CFEngine is an IT infrastructure automation framework \
7that helps engineers, system administrators and other stakeholders \
8in an IT system to manage and understand IT infrastructure throughout \
9its lifecycle. CFEngine takes systems from Build to Deploy, Manage and Audit. \
10 \
11This package is intended to provide a stable base policy for \
12installations and upgrades, and is used by CFEngine 3.6 and newer. \
13 \
14The contents of this packge are intended to live in `/var/cfengine/masterfiles` \
15or wherever `$(sys.masterdir)` points. \
16"
17
18HOMEPAGE = "http://cfengine.com"
19
20LICENSE = "MIT"
21LIC_FILES_CHKSUM = "file://LICENSE;md5=9f76426f9ef8c6f6739fadd21d817a4f"
22
23SRC_URI = "https://cfengine-package-repos.s3.amazonaws.com/tarballs/${BP}.tar.gz \
24 file://python3.patch \
25 "
26SRC_URI[md5sum] = "6d456fdd9bd24ff6617eeaa05efae602"
27SRC_URI[sha256sum] = "4a071c0c4ba7df9bad93144cff5fbc0566e5172afd66201072e3193b76c55a38"
28
29inherit autotools
30
31export EXPLICIT_VERSION="${PV}"
32
33EXTRA_OECONF = "--prefix=${datadir}/cfengine"
34
Patrick Williams213cb262021-08-07 19:21:33 -050035do_install:append() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050036 rm -rf ${D}${datadir}/cfengine/modules/packages/zypper ${D}${datadir}/cfengine/modules/packages/yum
37}
38
Patrick Williams213cb262021-08-07 19:21:33 -050039FILES:${PN} = "${datadir}/cfengine"
Andrew Geissler82c905d2020-04-13 13:39:40 -050040
Patrick Williams213cb262021-08-07 19:21:33 -050041RDEPENDS:${PN} += "python3-core"