blob: d1b288cf2edabdf9d2e607f053055637db6590dd [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Simple top-like I/O monitor"
2DESCRIPTION = "iotop does for I/O usage what top(1) does for CPU usage. \
3 It watches I/O usage information output by the Linux kernel and displays \
4 a table of current I/O usage by processes on the system."
5HOMEPAGE = "http://guichaz.free.fr/iotop/"
6
Patrick Williamsb48b7b42016-08-17 15:04:38 -05007LICENSE = "GPLv2+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4"
9
Andrew Geissler82c905d2020-04-13 13:39:40 -050010PV .= "+git${SRCPV}"
11
12SRCREV = "1bfb3bc70febb1ffb95146b6dcd65257228099a3"
13SRC_URI = "git://repo.or.cz/iotop.git"
14
15S = "${WORKDIR}/git"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050016
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080017UPSTREAM_CHECK_URI = "http://repo.or.cz/iotop.git/tags"
18UPSTREAM_CHECK_REGEX = "iotop-(?P<pver>\d+(\.\d+)+)"
19
Andrew Geissler82c905d2020-04-13 13:39:40 -050020inherit distutils3
Patrick Williamsb48b7b42016-08-17 15:04:38 -050021
Patrick Williams213cb262021-08-07 19:21:33 -050022do_install:append() {
Patrick Williamsb48b7b42016-08-17 15:04:38 -050023 rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/site.pyo || true
24 rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/site.py || true
25}
26
Patrick Williams213cb262021-08-07 19:21:33 -050027RDEPENDS:${PN} = "python3-curses \
Andrew Geissler82c905d2020-04-13 13:39:40 -050028 python3-codecs python3-ctypes python3-pprint \
29 python3-shell python3-core"