blob: d930b4348009caf97ffc488eb14222b4b331e01c [file] [log] [blame]
Andrew Geissler32b11992021-03-31 13:37:05 -05001# Copyright (C) 2021 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "A C library that may be linked into a C/C++ program to produce symbolic backtraces"
5HOMEPAGE = "https://github.com/ianlancetaylor/libbacktrace"
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=24b5b3feec63c4be0975e1fea5100440"
8
9DEPENDS += "libunwind"
10
11SRC_URI = "git://github.com/ianlancetaylor/libbacktrace;protocol=https"
12
13PV = "1.0+git${SRCPV}"
14SRCREV = "4f57c999716847e45505b3df170150876b545088"
15
16S = "${WORKDIR}/git"
17
18inherit autotools
19
20EXTR_OECONF += "--with-system-libunwind"
21
22CFLAGS += "-fPIC"
23
24do_configure() {
25 oe_runconf
26}
27
28# libunwind does not support RISCV yet
Patrick Williams213cb262021-08-07 19:21:33 -050029COMPATIBLE_HOST:riscv64 = "null"
30COMPATIBLE_HOST:riscv32 = "null"