blob: 602e9637522aa6ce7cf24b7f1df03baa633ae661 [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001# Copyright (C) 2019 Ruslan Bilovol <rbilovol@cisco.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "NSS module for glibc, to provide NIS+ support for glibc"
5
6DESCRIPTION = "This package contains the NSS NIS+ plugin for glibc.\
7This code was formerly part of glibc, but is now standalone to\
8be able to link against TI-RPC for IPv6 support."
9
10HOMEPAGE = "https://github.com/thkukuk/libnss_nisplus"
11LICENSE = "LGPL-2.1"
12LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
13SECTION = "libs"
14DEPENDS += "libtirpc libnsl2"
15
16PV = "1.3+git${SRCPV}"
17
Brad Bishop868407c2019-11-04 13:24:47 -050018SRCREV = "116219e215858f4af9370171d3ead63baca8fdb4"
Brad Bishop26bdd442019-08-16 17:08:17 -040019
20SRC_URI = "git://github.com/thkukuk/libnss_nisplus \
Brad Bishop26bdd442019-08-16 17:08:17 -040021 "
22
23S = "${WORKDIR}/git"
24
25inherit autotools pkgconfig
26
27BBCLASSEXTEND += "native nativesdk"
28#
29# We will skip parsing this packagegeoup for non-glibc systems
30#
Patrick Williams213cb262021-08-07 19:21:33 -050031COMPATIBLE_HOST:libc-musl = 'null'