blob: d14fbaed3ead9cef729d65279f1742be9911def6 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "An IPC library for high performance servers"
2DESCRIPTION = "libqb is a library with the primary purpose of providing high performance client server reusable features. \
3It provides high performance logging, tracing, ipc, and poll."
4
5HOMEPAGE = "https://github.com/clusterlabs/libqb/wiki"
6SECTION = "libs"
7LICENSE = "LGPL-2.1"
8LIC_FILES_CHKSUM = "file://COPYING;md5=321bf41f280cf805086dd5a720b37785"
9
10inherit autotools pkgconfig
11
12# v1.0.5
13SRCREV = "d08dbcf08b0da418bce9b5427dfd89522916322a"
14SRC_URI = "git://github.com/ClusterLabs/${BPN}.git;branch=version_1 \
15 file://0001-build-fix-configure-script-neglecting-re-enable-out-.patch \
16 "
17S = "${WORKDIR}/git"
18
19# otherwise do_configure fails
20# configure:21609: checking whether linker workaround for orphan sections usable
21# configure:21639: i586-oe-linux-gcc -m32 -march=i586 --sysroot=WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0/recipe-sysroot -o conftest -O -fno-omit-frame-pointer -g -feliminate-unused-debug-types -fdebug-prefix-map=WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0=/usr/src/debug/libqb/1.0.3+gitAUTOINC+c235284b5f-r0 -fdebug-prefix-map=WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0/recipe-sysroot= -fdebug-prefix-map=WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0/recipe-sysroot-native= -pipe -pthread -D_REENTRANT -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed -Wl,conftest.ld conftest.c >&5
22# WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0/recipe-sysroot-native/usr/bin/i586-oe-linux/../../libexec/i586-oe-linux/gcc/i586-oe-linux/8.1.0/ld: error: conftest.ld: SECTIONS seen after other input files; try -T/--script
23# WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0/recipe-sysroot-native/usr/bin/i586-oe-linux/../../libexec/i586-oe-linux/gcc/i586-oe-linux/8.1.0/ld: internal error in write_sections, at ../../gold/reloc.cc:791
24# collect2: error: ld returned 1 exit status
Brad Bishope42b3e32020-01-15 22:08:42 -050025NOSECTION_FALLBACK = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', '--enable-nosection-fallback', '', d)}"
Patrick Williams213cb262021-08-07 19:21:33 -050026NOSECTION_FALLBACK:toolchain-clang:mips64 = "--enable-nosection-fallback"
Brad Bishope42b3e32020-01-15 22:08:42 -050027
28EXTRA_OECONF += "${NOSECTION_FALLBACK}"
Brad Bishopc342db32019-05-15 21:57:59 -040029
30CFLAGS += "-pthread -D_REENTRANT"
Brad Bishope42b3e32020-01-15 22:08:42 -050031
Patrick Williams213cb262021-08-07 19:21:33 -050032do_configure:prepend() {
Brad Bishopc342db32019-05-15 21:57:59 -040033 ( cd ${S}
34 ${S}/autogen.sh )
35}
Andrew Geissler82c905d2020-04-13 13:39:40 -050036
37BBCLASSEXTEND = "native"