blob: 7741305f0191f34c61b979bf137ee8805de2baa0 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001DESCRIPTION = "Libraries providing API for reporting different problems in applications \
2to different bug targets like Bugzilla, ftp, trac, etc..."
3SUMMARY = "Generic library for reporting various problems"
4HOMEPAGE = "https://abrt.readthedocs.org/"
5LICENSE = "GPLv2+"
6DEPENDS = "xmlrpc-c xmlrpc-c-native intltool-native \
7 json-c libtar libnewt libproxy rpm \
8 augeas satyr systemd \
9"
10
11LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
12
13
14SRC_URI = "git://github.com/abrt/libreport.git;protocol=https"
15SRC_URI += "file://0001-Makefile.am-remove-doc-and-apidoc.patch \
16 file://0002-configure.ac-remove-prog-test-of-xmlto-and-asciidoc.patch \
17 file://0003-without-build-plugins.patch \
18 file://0004-configure.ac-remove-prog-test-of-augparse.patch \
19"
Brad Bishop26bdd442019-08-16 17:08:17 -040020SRCREV = "eaff08f38d771d9362923765bb404b1514c5ca0a"
Brad Bishop19323692019-04-05 15:28:33 -040021
22UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
23
24S = "${WORKDIR}/git"
25
Brad Bishop8410d612019-11-25 09:40:59 -050026inherit features_check
Brad Bishop19323692019-04-05 15:28:33 -040027REQUIRED_DISTRO_FEATURES = "systemd"
28
29inherit gettext autotools python3native pkgconfig
30
31PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES','x11','gtk','',d)}"
32PACKAGECONFIG[gtk] = "--with-gtk, --without-gtk, gtk+3,"
33
34EXTRA_OECONF += "--without-python2 --with-python3"
35
Patrick Williams213cb262021-08-07 19:21:33 -050036RDEPENDS:python3-libreport += "${PN}"
Brad Bishop19323692019-04-05 15:28:33 -040037
38do_patch[prefuncs] += "do_gen_version"
39do_gen_version() {
40 cd ${S}
41 ./gen-version
42}
43
44PACKAGES += "python3-libreport"
45
Patrick Williams213cb262021-08-07 19:21:33 -050046FILES:${PN} += "${datadir}/*"
47FILES:${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/*/.debug"
48FILES:python3-libreport = "${PYTHON_SITEPACKAGES_DIR}/*"
Brad Bishop19323692019-04-05 15:28:33 -040049