blob: f2ee97b9340eebf7b1ead4f66d1324967ce080c7 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Control and monitor storage systems using S.M.A.R.T"
2DESCRIPTION = "\
3The smartmontools package contains two utility programs (smartctl \
4and smartd) to control and monitor storage systems using the Self-\
5Monitoring, Analysis and Reporting Technology System (SMART) built \
6into most modern ATA and SCSI hard disks. In many cases, these \
7utilities will provide advanced warning of disk degradation and failure."
8
9HOMEPAGE = "http://smartmontools.sourceforge.net/"
10SECTION = "console/utils"
11
12LICENSE = "GPLv2"
13LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
14
15SRC_URI = "${SOURCEFORGE_MIRROR}/smartmontools/smartmontools-${PV}.tar.gz \
16 file://initd.smartd \
17 file://smartmontools.default \
18 file://smartd.service \
Andrew Geissler97771a32021-03-05 15:23:11 -060019 file://0001-configure.ac-Define-SOURCE_DATE_EPOCH-in-CPPFLAGS.patch \
Brad Bishop19323692019-04-05 15:28:33 -040020 "
21
22PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'libcap-ng selinux', d)}"
23PACKAGECONFIG[libcap-ng] = "--with-libcap-ng=yes,--with-libcap-ng=no,libcap-ng"
24PACKAGECONFIG[selinux] = "--with-selinux=yes,--with-selinux=no,libselinux"
25
Andrew Geissler72956ed2021-01-08 16:11:14 -060026SRC_URI[md5sum] = "e8d134c69ae4959a05cb56b31172ffb1"
27SRC_URI[sha256sum] = "5cd98a27e6393168bc6aaea070d9e1cd551b0f898c52f66b2ff2e5d274118cd6"
Brad Bishop19323692019-04-05 15:28:33 -040028
29inherit autotools update-rc.d systemd
30
Patrick Williams213cb262021-08-07 19:21:33 -050031SYSTEMD_SERVICE:${PN} = "smartd.service"
Brad Bishop19323692019-04-05 15:28:33 -040032SYSTEMD_AUTO_ENABLE = "disable"
33
Patrick Williams213cb262021-08-07 19:21:33 -050034do_install:append () {
Brad Bishop19323692019-04-05 15:28:33 -040035 #install the init.d/smartd
36 install -d ${D}${sysconfdir}/init.d
37 install -p -m 0755 ${WORKDIR}/initd.smartd ${D}${sysconfdir}/init.d/smartd
38 install -d ${D}${sysconfdir}/default
39 install -p -m 0644 ${WORKDIR}/smartmontools.default ${D}${sysconfdir}/default/smartmontools
40
41 #install systemd service file
42 install -d ${D}${systemd_unitdir}/system
43 install -m 0644 ${WORKDIR}/smartd.service ${D}${systemd_unitdir}/system
44 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
45 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
46 -e 's,@SBINDIR@,${sbindir},g' \
47 ${D}${systemd_unitdir}/system/smartd.service
48}
49
50INITSCRIPT_NAME = "smartd"
51INITSCRIPT_PARAMS = "start 60 2 3 4 5 . stop 60 0 1 6 ."
52
Patrick Williams213cb262021-08-07 19:21:33 -050053RDEPENDS:${PN} += "mailx"