blob: 31d0dae25c6563d702b9befaec269b4c502322d3 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Hardware performance monitoring counters"
2HOMEPAGE = "http://tiptop.gforge.inria.fr/"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08005DEPENDS = "ncurses libxml2 bison-native flex-native"
Brad Bishop316dfdd2018-06-25 12:45:53 -04006
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08007SRC_URI = "http://tiptop.gforge.inria.fr/releases/${BP}.tar.gz \
8 file://0001-Fix-parallel-build-problems-by-Adrian-Bunk.patch \
9 file://0002-fix-reproducibility-of-build-process.patch \
10 file://0001-Fix-build-when-S-B.patch \
11 "
Brad Bishop316dfdd2018-06-25 12:45:53 -040012SRC_URI[md5sum] = "46ca0fdf0236f02dd2b96d347626d2a2"
13SRC_URI[sha256sum] = "51c4449c95bba34f16b429729c2f58431490665d8093efaa8643b2e1d1084182"
14
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015inherit autotools
16
Brad Bishop316dfdd2018-06-25 12:45:53 -040017EXTRA_OECONF = "CFLAGS="$CFLAGS -I${STAGING_INCDIR}/libxml2""
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080018COMPATIBLE_HOST = "(i.86|x86_64|arm|powerpc|aarch64).*-linux"
Brad Bishop316dfdd2018-06-25 12:45:53 -040019
Patrick Williams213cb262021-08-07 19:21:33 -050020do_configure:prepend () {
Brad Bishop316dfdd2018-06-25 12:45:53 -040021 # Two bugs in configure.ac when cross-compiling.
22 # 1. The path of libxml2. Specify it in EXTRA_OECONF.
23 # 2. hw's value on other platforms. Replace it if the target is
24 # not i*86/x86_64.
25 if ( echo "${TARGET_ARCH}" | grep -q -e 'i.86' -e 'x86_64' ); then
26 sed -i 's= -I/usr/include/libxml2==' ${S}/configure.ac
27 else
28 sed -i 's/hw=`uname -m`/hw="unknown"/' ${S}/configure.ac
29 sed -i 's= -I/usr/include/libxml2==' ${S}/configure.ac
30 fi
31}