blob: fc3a6b79479c19558e37a5e39fffd1ec367c5f12 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001require ttf.inc
2
3SUMMARY = "Adobe OpenType Pan-CJK font family for Korean"
4HOMEPAGE = "https://github.com/adobe-fonts/source-han-sans"
5LICENSE = "OFL-1.1"
6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=55719faa0112708e946b820b24b14097"
7
8inherit allarch fontcache
9
10# Download tends to break - so - or not?
11#EXCLUDE_FROM_WORLD = "1"
12
13SRC_URI = " \
14 https://github.com/adobe-fonts/source-han-sans/raw/release/SubsetOTF/SourceHanSansKR.zip \
15 file://44-source-han-sans-kr.conf \
16"
17SRC_URI[md5sum] = "f8d1bd6c87d8575afdb25e2f46bd81d4"
18SRC_URI[sha256sum] = "38fd15c80f9980492faaa1af39ff873d8a38e45027023fb17d5b10d4b4b0e6af"
19
20S = "${WORKDIR}/SourceHanSansKR"
21
22do_install() {
23 install -d ${D}${sysconfdir}/fonts/conf.d/
24 install -m 0644 ${WORKDIR}/44-source-han-sans-kr.conf ${D}${sysconfdir}/fonts/conf.d/
25
26 install -d ${D}${datadir}/fonts/truetype/
27 find ./ -name '*.otf' -exec install -m 0644 {} ${D}${datadir}/fonts/truetype/ \;
28}
29
Patrick Williams213cb262021-08-07 19:21:33 -050030FILES:${PN} = " \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050031 ${sysconfdir}/fonts \
32 ${datadir}/fonts \
33"
34