blob: 23401329848208d8819ce314b884525d3823ad55 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "The GNU Compact Disc Input and Control library (libcdio) contains a library for CD-ROM and CD image access."
2HOMEPAGE = "http://www.gnu.org/software/libcdio/"
3SECTION = "libs"
4LICENSE = "GPLv3+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6
7SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.bz2"
8
9SRC_URI[md5sum] = "aa7629e8f73662a762f64c444b901055"
10SRC_URI[sha256sum] = "8550e9589dbd594bfac93b81ecf129b1dc9d0d51e90f9696f1b2f9b2af32712b"
11
12inherit autotools pkgconfig
13
14PACKAGECONFIG ??= "cdda-player"
15PACKAGECONFIG[cdda-player] = "--with-cdda-player,--without-cdda-player,ncurses"
16PACKAGECONFIG[cddb] = "--enable-cddb,--disable-cddb,libcddb"
17PACKAGECONFIG[vcd-info] = "--enable-vcd-info,--disable-vcd-info,vcdimager"
18
19PACKAGES += "${PN}-utils"
20
Patrick Williams213cb262021-08-07 19:21:33 -050021FILES:${PN} = "${libdir}/${BPN}${SOLIB}"
22FILES:${PN}-utils = "${bindir}/*"
Brad Bishopc342db32019-05-15 21:57:59 -040023
24python libcdio_split_packages() {
25 libdir = d.expand('${libdir}')
26 do_split_packages(d, libdir, '^lib(.*)\.so\..*', 'lib%s', 'libcdio %s library', extra_depends='', allow_links=True)
27}
28
29PACKAGESPLITFUNCS =+ "libcdio_split_packages"